mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
26 lines
951 B
Diff
26 lines
951 B
Diff
From 1d862091e7b7f49eb8533c74b6f7de34d6feb56c Mon Sep 17 00:00:00 2001
|
|
From: Camelia Groza <camelia.groza@nxp.com>
|
|
Date: Mon, 12 Aug 2019 15:58:07 +0300
|
|
Subject: [PATCH] sdk_dpaa: ceetm: update Makefile to use absolute include
|
|
paths
|
|
|
|
Explicitly mention the root source tree directory when building. This
|
|
allows the build process to start from a different location.
|
|
|
|
Signed-off-by: Camelia Groza <camelia.groza@nxp.com>
|
|
---
|
|
drivers/net/ethernet/freescale/sdk_dpaa/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/drivers/net/ethernet/freescale/sdk_dpaa/Makefile
|
|
+++ b/drivers/net/ethernet/freescale/sdk_dpaa/Makefile
|
|
@@ -18,7 +18,7 @@ ifeq ($(CONFIG_FSL_DPAA_1588),y)
|
|
fsl_dpa-objs += dpaa_1588.o
|
|
endif
|
|
ifeq ($(CONFIG_FSL_DPAA_CEETM),y)
|
|
-ccflags-y += -Idrivers/net/ethernet/freescale/sdk_fman/src/wrapper
|
|
+ccflags-y += -I$(srctree)/drivers/net/ethernet/freescale/sdk_fman/src/wrapper
|
|
fsl_dpa-objs += dpaa_eth_ceetm.o
|
|
endif
|
|
|