mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
97 lines
2.6 KiB
Diff
97 lines
2.6 KiB
Diff
From 5b35aae22b4ca2400e49561c9267aa01346f91d4 Mon Sep 17 00:00:00 2001
|
|
From: Mathew McBride <matt@traverse.com.au>
|
|
Date: Tue, 17 Apr 2018 10:01:03 +1000
|
|
Subject: [PATCH] add DTS for Traverse LS1043 Boards
|
|
|
|
Signed-off-by: Mathew McBride <matt@traverse.com.au>
|
|
[rebase]
|
|
Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|
---
|
|
arch/arm64/boot/dts/freescale/Makefile | 3 +++
|
|
arch/arm64/boot/dts/freescale/traverse-ls1043s.dts | 29 ++++++++++++++++++++++
|
|
arch/arm64/boot/dts/freescale/traverse-ls1043v.dts | 29 ++++++++++++++++++++++
|
|
3 files changed, 61 insertions(+)
|
|
|
|
--- a/arch/arm64/boot/dts/freescale/Makefile
|
|
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
|
@@ -48,6 +48,9 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-lx2160a-qds.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-lx2160a-rdb.dtb
|
|
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += traverse-ls1043v.dtb
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += traverse-ls1043s.dtb
|
|
+
|
|
dtb-$(CONFIG_ARCH_MXC) += imx8mm-evk.dtb
|
|
dtb-$(CONFIG_ARCH_MXC) += imx8mn-ddr4-evk.dtb
|
|
dtb-$(CONFIG_ARCH_MXC) += imx8mq-evk.dtb
|
|
--- a/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts
|
|
+++ b/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts
|
|
@@ -330,3 +330,32 @@
|
|
&sata {
|
|
status = "disabled";
|
|
};
|
|
+
|
|
+/* Additions for Layerscape SDK (4.4/4.9) Kernel only
|
|
+ * These kernels need additional setup for FMan/QMan DMA shared memory
|
|
+ */
|
|
+
|
|
+#include "qoriq-qman-portals-sdk.dtsi"
|
|
+#include "qoriq-bman-portals-sdk.dtsi"
|
|
+
|
|
+&bman_fbpr {
|
|
+ compatible = "fsl,bman-fbpr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_fqd {
|
|
+ compatible = "fsl,qman-fqd";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_pfdr {
|
|
+ compatible = "fsl,qman-pfdr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+
|
|
+&soc {
|
|
+#include "qoriq-dpaa-eth.dtsi"
|
|
+#include "qoriq-fman3-0-6oh.dtsi"
|
|
+};
|
|
+
|
|
+&fman0 {
|
|
+ compatible = "fsl,fman", "simple-bus";
|
|
+};
|
|
--- a/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts
|
|
+++ b/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts
|
|
@@ -251,3 +251,32 @@
|
|
&sata {
|
|
status = "disabled";
|
|
};
|
|
+
|
|
+/* Additions for Layerscape SDK (4.4/4.9) Kernel only
|
|
+ * These kernels need additional setup for FMan/QMan DMA shared memory
|
|
+ */
|
|
+
|
|
+#include "qoriq-qman-portals-sdk.dtsi"
|
|
+#include "qoriq-bman-portals-sdk.dtsi"
|
|
+
|
|
+&bman_fbpr {
|
|
+ compatible = "fsl,bman-fbpr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_fqd {
|
|
+ compatible = "fsl,qman-fqd";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+&qman_pfdr {
|
|
+ compatible = "fsl,qman-pfdr";
|
|
+ alloc-ranges = <0 0 0x10000 0>;
|
|
+};
|
|
+
|
|
+&soc {
|
|
+#include "qoriq-dpaa-eth.dtsi"
|
|
+#include "qoriq-fman3-0-6oh.dtsi"
|
|
+};
|
|
+
|
|
+&fman0 {
|
|
+ compatible = "fsl,fman", "simple-bus";
|
|
+};
|