mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-12 07:53:07 +00:00
997acc7f86
Backport at803x split patches merged upstream to tidy things up for the at803x PHY driver. New Kernel config are introduced hence any user needs to be updated. Downstream ipq40xx patch require rework to correctly move them to the qcom specific PHY directory. All affected patch automatically refreshed. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
50 lines
1.8 KiB
Diff
50 lines
1.8 KiB
Diff
From 876bb5b69c1e083be526c0ea261982d5eb78556f Mon Sep 17 00:00:00 2001
|
|
From: Robert Marko <robert.marko@sartura.hr>
|
|
Date: Fri, 9 Sep 2022 23:44:42 +0200
|
|
Subject: [PATCH] net: phy: Add Qualcom QCA807x driver
|
|
|
|
This adds driver for the Qualcomm QCA8072 and QCA8075 PHY-s.
|
|
|
|
They are 2 or 5 port IEEE 802.3 clause 22 compliant 10BASE-Te, 100BASE-TX and 1000BASE-T PHY-s.
|
|
|
|
They feature 2 SerDes, one for PSGMII or QSGMII connection with MAC, while second one is SGMII for connection to MAC or fiber.
|
|
|
|
Both models have a combo port that supports 1000BASE-X and 100BASE-FX fiber.
|
|
|
|
Each PHY inside of QCA807x series has 4 digitally controlled output only pins that natively drive LED-s.
|
|
But some vendors used these to driver generic LED-s controlled by userspace,
|
|
so lets enable registering each PHY as GPIO controller and add driver for it.
|
|
|
|
These are commonly used in Qualcomm IPQ40xx, IPQ60xx and IPQ807x boards.
|
|
|
|
Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
|
---
|
|
drivers/net/phy/Kconfig | 7 +++++++
|
|
drivers/net/phy/Makefile | 1 +
|
|
2 files changed, 8 insertions(+)
|
|
|
|
--- a/drivers/net/phy/qcom/Kconfig
|
|
+++ b/drivers/net/phy/qcom/Kconfig
|
|
@@ -15,6 +15,13 @@ config QCA83XX_PHY
|
|
help
|
|
Currently supports the internal QCA8337(Internal qca8k PHY) model
|
|
|
|
+config QCA807X_PHY
|
|
+ tristate "Qualcomm QCA807x PHYs"
|
|
+ depends on OF_MDIO
|
|
+ help
|
|
+ Currently supports the Qualcomm QCA8072, QCA8075 and the PSGMII
|
|
+ control PHY.
|
|
+
|
|
config QCA808X_PHY
|
|
tristate "Qualcomm QCA808x PHYs"
|
|
select QCOM_NET_PHYLIB
|
|
--- a/drivers/net/phy/qcom/Makefile
|
|
+++ b/drivers/net/phy/qcom/Makefile
|
|
@@ -2,4 +2,5 @@
|
|
obj-$(CONFIG_QCOM_NET_PHYLIB) += qcom-phy-lib.o
|
|
obj-$(CONFIG_AT803X_PHY) += at803x.o
|
|
obj-$(CONFIG_QCA83XX_PHY) += qca83xx.o
|
|
+obj-$(CONFIG_QCA807X_PHY) += qca807x.o
|
|
obj-$(CONFIG_QCA808X_PHY) += qca808x.o
|