mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
37 lines
1.3 KiB
Diff
37 lines
1.3 KiB
Diff
From 911d3d1ea88ff6d56258d6173be7fc25290948a7 Mon Sep 17 00:00:00 2001
|
|
From: Dong Aisheng <aisheng.dong@nxp.com>
|
|
Date: Fri, 10 Jan 2020 12:51:49 +0800
|
|
Subject: [PATCH] LF-789-2 arm64: dts: add overlay support for ls1028a-qds
|
|
|
|
Now seems only ls1028a-qds using overlay by adding fragment dtbs.
|
|
Add their support in Makefile.
|
|
|
|
This is one of approach suggested by DT maintainer Rob here:
|
|
https://lore.kernel.org/patchwork/patch/821645/
|
|
|
|
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
|
|
Signed-off-by: Jason Liu <jason.hui.liu@nxp.com>
|
|
Reviewed-by: Alex Marginean <alexandru.marginean@nxp.com>
|
|
Tested-by: Alex Marginean <alexandru.marginean@nxp.com>
|
|
---
|
|
arch/arm64/boot/dts/freescale/Makefile | 10 ++++++++++
|
|
1 file changed, 10 insertions(+)
|
|
|
|
--- a/arch/arm64/boot/dts/freescale/Makefile
|
|
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
|
@@ -1,4 +1,14 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
+
|
|
+# required for overlay support
|
|
+DTC_FLAGS_fsl-ls1028a-qds := -@
|
|
+DTC_FLAGS_fsl-ls1028a-qds-13bb := -@
|
|
+DTC_FLAGS_fsl-ls1028a-qds-65bb := -@
|
|
+DTC_FLAGS_fsl-ls1028a-qds-7777 := -@
|
|
+DTC_FLAGS_fsl-ls1028a-qds-85bb := -@
|
|
+DTC_FLAGS_fsl-ls1028a-qds-899b := -@
|
|
+DTC_FLAGS_fsl-ls1028a-qds-9999 := -@
|
|
+
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-2g5rdb.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frdm.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frwy.dtb
|