mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
51fe956c4f
Buffalo WXR-2533DHP is a 2.4/5 GHz band 11ac router, based on Qualcomm IPQ8064. The U-Boot on WXR-2533DHP employs a complicated dual firmware protection scheme against corruptions of the kernel and rootfs images. See the notes in buffalo.sh for details. specifications: - Qualcomm IPQ8064 (384 - 1,400 MHz, 2C2T) - 512 MB of RAM (DDR3) - 256 MB of Flash (NAND) - 4T4R 2.4/5 GHz Wlan (QCA9980) - 5x 10/100/1000 Mbps Ethernet - 10x LEDs, 8x keys (6x buttons, 2x slide-switches) - 2x USB 3.0 Type-A - 12VDC/4A AC Adapter - UART through-hole on PCB - J3: Vcc, GND, TX, RX from USB port side - 115200n8 Boot instructions for the initramfs image: 1. Prepare the TFTP server with the initramfs image renamed to "wxr2300dhp-initramfs.uImage" and IP address "192.168.11.10". 2. Press the "AOSS" button while powering on the WXR-2533DHP. 3. Wait until the "Wireless" LED flashes before releasing the AOSS button. The WXR-2533DHP will grab the image from TFTP server and will boot it. Flashing instructions: To persistently write the firmware, flash an openwrt sysupgrade image from inside the initramfs, for example transfer via `scp <sysupgrade> root@192.168.1.1:/tmp` and flash on the device with `sysupgrade -n /tmp/<sysupgrade>`. Then wait ~120 seconds to let it finish the flashing process. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [reworded message]
32 lines
956 B
Diff
32 lines
956 B
Diff
From 8f68331e14dff9a101f2d0e1d6bec84a031f27ee Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 9 Mar 2017 11:03:18 +0100
|
|
Subject: [PATCH 69/69] arm: boot: add dts files
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -699,6 +699,18 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8084-mtp.dtb \
|
|
qcom-ipq4019-ap.dk01.1-c1.dtb \
|
|
qcom-ipq8064-ap148.dtb \
|
|
+ qcom-ipq8064-c2600.dtb \
|
|
+ qcom-ipq8064-d7800.dtb \
|
|
+ qcom-ipq8064-db149.dtb \
|
|
+ qcom-ipq8064-ap161.dtb \
|
|
+ qcom-ipq8064-ea8500.dtb \
|
|
+ qcom-ipq8064-r7500.dtb \
|
|
+ qcom-ipq8064-r7500v2.dtb \
|
|
+ qcom-ipq8064-wg2600hp.dtb \
|
|
+ qcom-ipq8064-wpq864.dtb \
|
|
+ qcom-ipq8064-wxr-2533dhp.dtb \
|
|
+ qcom-ipq8065-nbg6817.dtb \
|
|
+ qcom-ipq8065-r7800.dtb \
|
|
qcom-msm8660-surf.dtb \
|
|
qcom-msm8960-cdp.dtb \
|
|
qcom-msm8974-lge-nexus5-hammerhead.dtb \
|