mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
120 lines
2.7 KiB
Diff
120 lines
2.7 KiB
Diff
From f0f46229b2232595a1afde10f6f17e512c004042 Mon Sep 17 00:00:00 2001
|
|
From: Gagandeep Singh <g.singh@nxp.com>
|
|
Date: Thu, 6 Feb 2020 13:01:10 +0000
|
|
Subject: [PATCH] LF-881: arm64: dts: add a dts file for dpdk
|
|
|
|
A new device tree file fsl-ls1028a-rdb-dpdk.dts is added
|
|
for user space networking.
|
|
|
|
Signed-off-by: Gagandeep Singh <g.singh@nxp.com>
|
|
Reviewed-by: Alex Marginean <alexandru.marginean@nxp.com>
|
|
Reviewed-by: Li Yang <leoyang.li@nxp.com>
|
|
---
|
|
arch/arm64/boot/dts/freescale/Makefile | 1 +
|
|
.../boot/dts/freescale/fsl-ls1028a-rdb-dpdk.dts | 89 ++++++++++++++++++++++
|
|
2 files changed, 90 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls1028a-rdb-dpdk.dts
|
|
|
|
--- a/arch/arm64/boot/dts/freescale/Makefile
|
|
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
|
@@ -23,6 +23,7 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-qds-899b.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-qds-9999.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-rdb.dtb
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-rdb-dpdk.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-qds.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-qds-sdk.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-rdb.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a-rdb-dpdk.dts
|
|
@@ -0,0 +1,89 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * NXP LS1028A RDB Board device tree file for DPDK
|
|
+ *
|
|
+ * Copyright 2018-2020 NXP
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "fsl-ls1028a-rdb.dts"
|
|
+
|
|
+&enetc_port0 {
|
|
+ status = "okay";
|
|
+ /delete-property/ phy-handle;
|
|
+ /delete-property/ phy-connection-type;
|
|
+ /delete-node/ mdio;
|
|
+
|
|
+ fixed-link {
|
|
+ speed = <1000>;
|
|
+ full-duplex;
|
|
+ };
|
|
+};
|
|
+
|
|
+/delete-node/ &enetc_mdio_pf3;
|
|
+
|
|
+/* l2switch ports */
|
|
+&mscc_felix_ports {
|
|
+ port@0 {
|
|
+ status = "okay";
|
|
+ phy-mode = "qsgmii";
|
|
+ /delete-property/ managed;
|
|
+ /delete-property/ phy-handle;
|
|
+
|
|
+ fixed-link {
|
|
+ speed = <1000>;
|
|
+ full-duplex;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ port@1 {
|
|
+ status = "okay";
|
|
+ phy-mode = "qsgmii";
|
|
+ /delete-property/ managed;
|
|
+ /delete-property/ phy-handle;
|
|
+
|
|
+ fixed-link {
|
|
+ speed = <1000>;
|
|
+ full-duplex;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ port@2 {
|
|
+ status = "okay";
|
|
+ phy-mode = "qsgmii";
|
|
+ /delete-property/ managed;
|
|
+ /delete-property/ phy-handle;
|
|
+
|
|
+ fixed-link {
|
|
+ speed = <1000>;
|
|
+ full-duplex;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ port@3 {
|
|
+ status = "okay";
|
|
+ phy-mode = "qsgmii";
|
|
+ /delete-property/ managed;
|
|
+ /delete-property/ phy-handle;
|
|
+
|
|
+ fixed-link {
|
|
+ speed = <1000>;
|
|
+ full-duplex;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ port@5 {
|
|
+ status = "okay";
|
|
+ /delete-property/ managed;
|
|
+ /delete-property/ phy-handle;
|
|
+
|
|
+ fixed-link {
|
|
+ speed = <1000>;
|
|
+ full-duplex;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&enetc_port3 {
|
|
+ status = "okay";
|
|
+};
|