mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
115 lines
2.7 KiB
Diff
115 lines
2.7 KiB
Diff
From 3261cabf5607c9f434faa4930ab5c2b0150579c4 Mon Sep 17 00:00:00 2001
|
|
From: Bhaskar Upadhaya <Bhaskar.Upadhaya@nxp.com>
|
|
Date: Wed, 29 Nov 2017 06:23:14 +0530
|
|
Subject: [PATCH] arm64: dts: ls1012a: Add LS1012A-2G5RDB board support
|
|
|
|
LS1012A-2G5RDB is a different design from LS1012ARDB,
|
|
but has some common SoC features. Key feature on this
|
|
board is 2.5Gbps SGMII.
|
|
|
|
Signed-off-by: Bhaskar Upadhaya <Bhaskar.Upadhaya@nxp.com>
|
|
Signed-off-by: Li Yang <leoyang.li@nxp.com>
|
|
---
|
|
arch/arm64/boot/dts/freescale/Makefile | 1 +
|
|
.../boot/dts/freescale/fsl-ls1012a-2g5rdb.dts | 86 ++++++++++++++++++++++
|
|
2 files changed, 87 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls1012a-2g5rdb.dts
|
|
|
|
--- a/arch/arm64/boot/dts/freescale/Makefile
|
|
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
|
@@ -1,4 +1,5 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-2g5rdb.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frdm.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frwy.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-oxalis.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1012a-2g5rdb.dts
|
|
@@ -0,0 +1,86 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * Device Tree file for NXP LS1012A 2G5RDB Board.
|
|
+ *
|
|
+ * Copyright 2017 NXP
|
|
+ *
|
|
+ * Bhaskar Upadhaya <bhaskar.upadhaya@nxp.com>
|
|
+ */
|
|
+/dts-v1/;
|
|
+
|
|
+#include "fsl-ls1012a.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "LS1012A 2G5RDB Board";
|
|
+ compatible = "fsl,ls1012a-rdb", "fsl,ls1012a";
|
|
+
|
|
+ aliases {
|
|
+ ethernet0 = &pfe_mac0;
|
|
+ ethernet1 = &pfe_mac1;
|
|
+ };
|
|
+};
|
|
+
|
|
+&duart0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&i2c0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&qspi {
|
|
+ num-cs = <2>;
|
|
+ bus-num = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ qflash0: s25fs512s@0 {
|
|
+ compatible = "spansion,m25p80";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ spi-max-frequency = <20000000>;
|
|
+ m25p,fast-read;
|
|
+ reg = <0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&sata {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pfe {
|
|
+ status = "okay";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ ethernet@0 {
|
|
+ compatible = "fsl,pfe-gemac-port";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ reg = <0x0>; /* GEM_ID */
|
|
+ fsl,gemac-bus-id = <0x0>; /* BUS_ID */
|
|
+ fsl,gemac-phy-id = <0x1>; /* PHY_ID */
|
|
+ fsl,mdio-mux-val = <0x0>;
|
|
+ phy-mode = "sgmii-2500";
|
|
+ fsl,pfe-phy-if-flags = <0x0>;
|
|
+
|
|
+ mdio@0 {
|
|
+ reg = <0x1>; /* enabled/disabled */
|
|
+ };
|
|
+ };
|
|
+
|
|
+ ethernet@1 {
|
|
+ compatible = "fsl,pfe-gemac-port";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ reg = <0x1>; /* GEM_ID */
|
|
+ fsl,gemac-bus-id = < 0x0>; /* BUS_ID */
|
|
+ fsl,gemac-phy-id = < 0x2>; /* PHY_ID */
|
|
+ fsl,mdio-mux-val = <0x0>;
|
|
+ phy-mode = "sgmii-2500";
|
|
+ fsl,pfe-phy-if-flags = <0x0>;
|
|
+
|
|
+ mdio@0 {
|
|
+ reg = <0x0>; /* enabled/disabled */
|
|
+ };
|
|
+ };
|
|
+};
|