mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
23 lines
773 B
Diff
23 lines
773 B
Diff
From 67d8e64b7f996a6398ff3aef6834e12540d3f51f Mon Sep 17 00:00:00 2001
|
|
From: Madalin Bucur <madalin.bucur@nxp.com>
|
|
Date: Fri, 30 Jun 2017 09:19:52 +0300
|
|
Subject: [PATCH] net: Makefile: re-add DPAA SDK drivers
|
|
|
|
Signed-off-by: Madalin Bucur <madalin.bucur@nxp.com>
|
|
---
|
|
drivers/net/ethernet/freescale/Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/drivers/net/ethernet/freescale/Makefile
|
|
+++ b/drivers/net/ethernet/freescale/Makefile
|
|
@@ -19,6 +19,9 @@ gianfar_driver-objs := gianfar.o \
|
|
obj-$(CONFIG_UCC_GETH) += ucc_geth_driver.o
|
|
ucc_geth_driver-objs := ucc_geth.o ucc_geth_ethtool.o
|
|
|
|
+obj-$(if $(CONFIG_FSL_SDK_FMAN),y) += sdk_fman/
|
|
+obj-$(if $(CONFIG_FSL_SDK_DPAA_ETH),y) += sdk_dpaa/
|
|
+
|
|
obj-$(CONFIG_FSL_FMAN) += fman/
|
|
obj-$(CONFIG_FSL_DPAA_ETH) += dpaa/
|
|
|