mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-26 06:09:37 +00:00
8925c469f4
This LED controller has a driver under development which is currently being reviewed by the respective kernel maintainers. They are currently on v11 which is included here. The LED1202 is a 12-channel low quiescent current LED driver with: * Supply range from 2.6 V to 5 V * 20 mA current capability per channel * 1.8 V compatible I2C control interface * 8-bit analog dimming individual control * 12-bit local PWM resolution * 8 programmable patterns If the led node is present in the controller then the channel is set to active. The output current can be adjusted separately for each channel by 8-bit analog (current sink input) and 12-bit digital (PWM) dimming control. The LED1202 implements 12 low-side current generators with independent dimming control. Internal volatile memory allows the user to store up to 8 different patterns, each pattern is a particular output configuration in terms of PWM duty-cycle (on 4096 steps). Analog dimming (on 256 steps) is per channel but common to all patterns. Each device tree LED node will have a corresponding entry in /sys/class/leds with the label name. The brightness property corresponds to the per channel analog dimming, while the patterns[1-8] to the PWM dimming control. Signed-off-by: Manuel Fombuena <fombuena@outlook.com> Link: https://github.com/openwrt/openwrt/pull/17451 Signed-off-by: Robert Marko <robimarko@gmail.com>
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
---
|
|
drivers/leds/Kconfig | 10 ++++++++++
|
|
drivers/leds/Makefile | 1 +
|
|
2 files changed, 11 insertions(+)
|
|
|
|
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -911,6 +911,16 @@ source "drivers/leds/flash/Kconfig"
|
|
comment "RGB LED drivers"
|
|
source "drivers/leds/rgb/Kconfig"
|
|
|
|
+config LEDS_SMARTRG_LED
|
|
+ tristate "LED support for Adtran SmartRG"
|
|
+ depends on LEDS_CLASS && I2C && OF
|
|
+ help
|
|
+ This option enables support for the Adtran SmartRG platform
|
|
+ system LED driver.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module
|
|
+ will be called leds-smartrg-system.
|
|
+
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -78,6 +78,7 @@ obj-$(CONFIG_LEDS_POWERNV) += leds-powe
|
|
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
|
|
obj-$(CONFIG_LEDS_SC27XX_BLTC) += leds-sc27xx-bltc.o
|
|
+obj-$(CONFIG_LEDS_SMARTRG_LED) += leds-smartrg-system.o
|
|
obj-$(CONFIG_LEDS_ST1202) += leds-st1202.o
|
|
obj-$(CONFIG_LEDS_SUNFIRE) += leds-sunfire.o
|
|
obj-$(CONFIG_LEDS_SYSCON) += leds-syscon.o
|