mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
99545b4bb1
This target adds support for the Allwinner D1 RISC-V based SoCs. - RISC-V single-core T-Head C906 (RV64GCV) - Tensilica HiFi4 DSP - DDR2/DDR3 support - 10/100/1000M ethernet - usual peripherals like USB2, SPI, I2C, PWM, etc. Four boards are supported: - Dongshan Nezha STU - 512Mb RAM - ethernet - LicheePi RV Dock - 512Mb RAM - wireless-only (RTL8723DS) - MangoPi MQ-Pro - 512Mb RAM - there are pads available for an SPI flash - wireless-only (RTL8723DS) - Nezha D1 - 512Mb/1Gb/2Gb RAM - 256Mb NAND flash - ethernet, wireless Installation: Standard SD-card installation via dd-ing the generated image to an SD-card of at least 256Mb. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
295 lines
8.5 KiB
Diff
295 lines
8.5 KiB
Diff
From ad842bfb2eb10a75050dd69145ca59de982eb0e9 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Holland <samuel@sholland.org>
|
|
Date: Sun, 17 Jul 2022 11:46:52 -0500
|
|
Subject: [PATCH 021/117] regulator: sun20i: Add support for Allwinner D1 LDOs
|
|
|
|
D1 contains two pairs of LDOs. Since they have similar bindings, and
|
|
they always exist together, put them in a single driver.
|
|
|
|
The analog LDOs are relatively boring, with a single linear range. Their
|
|
one quirk is that a bandgap reference must be calibrated for them to
|
|
produce the correct voltage.
|
|
|
|
The system LDOs have the complication that their voltage step is not an
|
|
integer, so a custom .list_voltage is needed to get the rounding right.
|
|
|
|
Series-changes: 2
|
|
- Use decimal numbers for .n_voltages instead of field widths
|
|
- Get the regmap from the parent device instead of a property/phandle
|
|
|
|
Series-changes: 3
|
|
- Adjust control flow in sun20i_regulator_get_regmap() for clarity
|
|
|
|
Reviewed-by: Heiko Stuebner <heiko@sntech.de>
|
|
Tested-by: Heiko Stuebner <heiko@sntech.de>
|
|
Signed-off-by: Samuel Holland <samuel@sholland.org>
|
|
---
|
|
drivers/regulator/Kconfig | 8 +
|
|
drivers/regulator/Makefile | 1 +
|
|
drivers/regulator/sun20i-regulator.c | 232 +++++++++++++++++++++++++++
|
|
3 files changed, 241 insertions(+)
|
|
create mode 100644 drivers/regulator/sun20i-regulator.c
|
|
|
|
--- a/drivers/regulator/Kconfig
|
|
+++ b/drivers/regulator/Kconfig
|
|
@@ -1280,6 +1280,14 @@ config REGULATOR_STW481X_VMMC
|
|
This driver supports the internal VMMC regulator in the STw481x
|
|
PMIC chips.
|
|
|
|
+config REGULATOR_SUN20I
|
|
+ tristate "Allwinner D1 internal LDOs"
|
|
+ depends on ARCH_SUNXI || COMPILE_TEST
|
|
+ depends on MFD_SYSCON && NVMEM
|
|
+ default ARCH_SUNXI
|
|
+ help
|
|
+ This driver supports the internal LDOs in the Allwinner D1 SoC.
|
|
+
|
|
config REGULATOR_SY7636A
|
|
tristate "Silergy SY7636A voltage regulator"
|
|
depends on MFD_SY7636A
|
|
--- a/drivers/regulator/Makefile
|
|
+++ b/drivers/regulator/Makefile
|
|
@@ -150,6 +150,7 @@ obj-$(CONFIG_REGULATOR_STM32_VREFBUF) +=
|
|
obj-$(CONFIG_REGULATOR_STM32_PWR) += stm32-pwr.o
|
|
obj-$(CONFIG_REGULATOR_STPMIC1) += stpmic1_regulator.o
|
|
obj-$(CONFIG_REGULATOR_STW481X_VMMC) += stw481x-vmmc.o
|
|
+obj-$(CONFIG_REGULATOR_SUN20I) += sun20i-regulator.o
|
|
obj-$(CONFIG_REGULATOR_SY7636A) += sy7636a-regulator.o
|
|
obj-$(CONFIG_REGULATOR_SY8106A) += sy8106a-regulator.o
|
|
obj-$(CONFIG_REGULATOR_SY8824X) += sy8824x.o
|
|
--- /dev/null
|
|
+++ b/drivers/regulator/sun20i-regulator.c
|
|
@@ -0,0 +1,232 @@
|
|
+// SPDX-License-Identifier: GPL-2.0-only
|
|
+//
|
|
+// Copyright (c) 2021-2022 Samuel Holland <samuel@sholland.org>
|
|
+//
|
|
+
|
|
+#include <linux/mfd/syscon.h>
|
|
+#include <linux/module.h>
|
|
+#include <linux/nvmem-consumer.h>
|
|
+#include <linux/of_device.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <linux/regmap.h>
|
|
+#include <linux/regulator/driver.h>
|
|
+
|
|
+#define SUN20I_POWER_REG 0x348
|
|
+
|
|
+#define SUN20I_SYS_LDO_CTRL_REG 0x150
|
|
+
|
|
+struct sun20i_regulator_data {
|
|
+ int (*init)(struct device *dev,
|
|
+ struct regmap *regmap);
|
|
+ const struct regulator_desc *descs;
|
|
+ unsigned int ndescs;
|
|
+};
|
|
+
|
|
+static int sun20i_d1_analog_ldos_init(struct device *dev, struct regmap *regmap)
|
|
+{
|
|
+ u8 bg_trim;
|
|
+ int ret;
|
|
+
|
|
+ ret = nvmem_cell_read_u8(dev, "bg_trim", &bg_trim);
|
|
+ if (ret)
|
|
+ return dev_err_probe(dev, ret, "Failed to get bg_trim value\n");
|
|
+
|
|
+ /* The default value corresponds to 900 mV. */
|
|
+ if (!bg_trim)
|
|
+ bg_trim = 0x19;
|
|
+
|
|
+ return regmap_update_bits(regmap, SUN20I_POWER_REG,
|
|
+ GENMASK(7, 0), bg_trim);
|
|
+}
|
|
+
|
|
+static const struct regulator_ops sun20i_d1_analog_ldo_ops = {
|
|
+ .list_voltage = regulator_list_voltage_linear,
|
|
+ .map_voltage = regulator_map_voltage_linear,
|
|
+ .set_voltage_sel = regulator_set_voltage_sel_regmap,
|
|
+ .get_voltage_sel = regulator_get_voltage_sel_regmap,
|
|
+ .enable = regulator_enable_regmap,
|
|
+ .disable = regulator_disable_regmap,
|
|
+ .is_enabled = regulator_is_enabled_regmap,
|
|
+};
|
|
+
|
|
+static const struct regulator_desc sun20i_d1_analog_ldo_descs[] = {
|
|
+ {
|
|
+ .name = "aldo",
|
|
+ .supply_name = "vdd33",
|
|
+ .of_match = "aldo",
|
|
+ .ops = &sun20i_d1_analog_ldo_ops,
|
|
+ .type = REGULATOR_VOLTAGE,
|
|
+ .owner = THIS_MODULE,
|
|
+ .n_voltages = 8,
|
|
+ .min_uV = 1650000,
|
|
+ .uV_step = 50000,
|
|
+ .vsel_reg = SUN20I_POWER_REG,
|
|
+ .vsel_mask = GENMASK(14, 12),
|
|
+ .enable_reg = SUN20I_POWER_REG,
|
|
+ .enable_mask = BIT(31),
|
|
+ },
|
|
+ {
|
|
+ .name = "hpldo",
|
|
+ .supply_name = "hpldoin",
|
|
+ .of_match = "hpldo",
|
|
+ .ops = &sun20i_d1_analog_ldo_ops,
|
|
+ .type = REGULATOR_VOLTAGE,
|
|
+ .owner = THIS_MODULE,
|
|
+ .n_voltages = 8,
|
|
+ .min_uV = 1650000,
|
|
+ .uV_step = 50000,
|
|
+ .vsel_reg = SUN20I_POWER_REG,
|
|
+ .vsel_mask = GENMASK(10, 8),
|
|
+ .enable_reg = SUN20I_POWER_REG,
|
|
+ .enable_mask = BIT(30),
|
|
+ },
|
|
+};
|
|
+
|
|
+static const struct sun20i_regulator_data sun20i_d1_analog_ldos = {
|
|
+ .init = sun20i_d1_analog_ldos_init,
|
|
+ .descs = sun20i_d1_analog_ldo_descs,
|
|
+ .ndescs = ARRAY_SIZE(sun20i_d1_analog_ldo_descs),
|
|
+};
|
|
+
|
|
+/* regulator_list_voltage_linear() modified for the non-integral uV_step. */
|
|
+static int sun20i_d1_system_ldo_list_voltage(struct regulator_dev *rdev,
|
|
+ unsigned int selector)
|
|
+{
|
|
+ const struct regulator_desc *desc = rdev->desc;
|
|
+ unsigned int uV;
|
|
+
|
|
+ if (selector >= desc->n_voltages)
|
|
+ return -EINVAL;
|
|
+
|
|
+ uV = desc->min_uV + (desc->uV_step * selector);
|
|
+
|
|
+ /* Produce correctly-rounded absolute voltages. */
|
|
+ return uV + ((selector + 1 + (desc->min_uV % 4)) / 3);
|
|
+}
|
|
+
|
|
+static const struct regulator_ops sun20i_d1_system_ldo_ops = {
|
|
+ .list_voltage = sun20i_d1_system_ldo_list_voltage,
|
|
+ .map_voltage = regulator_map_voltage_ascend,
|
|
+ .set_voltage_sel = regulator_set_voltage_sel_regmap,
|
|
+ .get_voltage_sel = regulator_get_voltage_sel_regmap,
|
|
+};
|
|
+
|
|
+static const struct regulator_desc sun20i_d1_system_ldo_descs[] = {
|
|
+ {
|
|
+ .name = "ldoa",
|
|
+ .supply_name = "ldo-in",
|
|
+ .of_match = "ldoa",
|
|
+ .ops = &sun20i_d1_system_ldo_ops,
|
|
+ .type = REGULATOR_VOLTAGE,
|
|
+ .owner = THIS_MODULE,
|
|
+ .n_voltages = 32,
|
|
+ .min_uV = 1600000,
|
|
+ .uV_step = 13333, /* repeating */
|
|
+ .vsel_reg = SUN20I_SYS_LDO_CTRL_REG,
|
|
+ .vsel_mask = GENMASK(7, 0),
|
|
+ },
|
|
+ {
|
|
+ .name = "ldob",
|
|
+ .supply_name = "ldo-in",
|
|
+ .of_match = "ldob",
|
|
+ .ops = &sun20i_d1_system_ldo_ops,
|
|
+ .type = REGULATOR_VOLTAGE,
|
|
+ .owner = THIS_MODULE,
|
|
+ .n_voltages = 64,
|
|
+ .min_uV = 1166666,
|
|
+ .uV_step = 13333, /* repeating */
|
|
+ .vsel_reg = SUN20I_SYS_LDO_CTRL_REG,
|
|
+ .vsel_mask = GENMASK(15, 8),
|
|
+ },
|
|
+};
|
|
+
|
|
+static const struct sun20i_regulator_data sun20i_d1_system_ldos = {
|
|
+ .descs = sun20i_d1_system_ldo_descs,
|
|
+ .ndescs = ARRAY_SIZE(sun20i_d1_system_ldo_descs),
|
|
+};
|
|
+
|
|
+static const struct of_device_id sun20i_regulator_of_match[] = {
|
|
+ {
|
|
+ .compatible = "allwinner,sun20i-d1-analog-ldos",
|
|
+ .data = &sun20i_d1_analog_ldos,
|
|
+ },
|
|
+ {
|
|
+ .compatible = "allwinner,sun20i-d1-system-ldos",
|
|
+ .data = &sun20i_d1_system_ldos,
|
|
+ },
|
|
+ { },
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, sun20i_regulator_of_match);
|
|
+
|
|
+static struct regmap *sun20i_regulator_get_regmap(struct device *dev)
|
|
+{
|
|
+ struct regmap *regmap;
|
|
+
|
|
+ /*
|
|
+ * First try the syscon interface. The system control device is not
|
|
+ * compatible with "syscon", so fall back to getting the regmap from
|
|
+ * its platform device. This is ugly, but required for devicetree
|
|
+ * backward compatibility.
|
|
+ */
|
|
+ regmap = syscon_node_to_regmap(dev->parent->of_node);
|
|
+ if (!IS_ERR(regmap))
|
|
+ return regmap;
|
|
+
|
|
+ regmap = dev_get_regmap(dev->parent, NULL);
|
|
+ if (regmap)
|
|
+ return regmap;
|
|
+
|
|
+ return ERR_PTR(-EPROBE_DEFER);
|
|
+}
|
|
+
|
|
+static int sun20i_regulator_probe(struct platform_device *pdev)
|
|
+{
|
|
+ const struct sun20i_regulator_data *data;
|
|
+ struct device *dev = &pdev->dev;
|
|
+ struct regulator_config config;
|
|
+ struct regmap *regmap;
|
|
+ int ret;
|
|
+
|
|
+ data = of_device_get_match_data(dev);
|
|
+ if (!data)
|
|
+ return -EINVAL;
|
|
+
|
|
+ regmap = sun20i_regulator_get_regmap(dev);
|
|
+ if (IS_ERR(regmap))
|
|
+ return dev_err_probe(dev, PTR_ERR(regmap), "Failed to get regmap\n");
|
|
+
|
|
+ if (data->init) {
|
|
+ ret = data->init(dev, regmap);
|
|
+ if (ret)
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ config = (struct regulator_config) {
|
|
+ .dev = dev,
|
|
+ .regmap = regmap,
|
|
+ };
|
|
+
|
|
+ for (unsigned int i = 0; i < data->ndescs; ++i) {
|
|
+ const struct regulator_desc *desc = &data->descs[i];
|
|
+ struct regulator_dev *rdev;
|
|
+
|
|
+ rdev = devm_regulator_register(dev, desc, &config);
|
|
+ if (IS_ERR(rdev))
|
|
+ return PTR_ERR(rdev);
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static struct platform_driver sun20i_regulator_driver = {
|
|
+ .probe = sun20i_regulator_probe,
|
|
+ .driver = {
|
|
+ .name = "sun20i-regulator",
|
|
+ .of_match_table = sun20i_regulator_of_match,
|
|
+ },
|
|
+};
|
|
+module_platform_driver(sun20i_regulator_driver);
|
|
+
|
|
+MODULE_AUTHOR("Samuel Holland <samuel@sholland.org>");
|
|
+MODULE_DESCRIPTION("Allwinner D1 internal LDO driver");
|
|
+MODULE_LICENSE("GPL");
|