mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
108 lines
3.3 KiB
Diff
108 lines
3.3 KiB
Diff
From c0dd62d0bc48c0d9e833116ea2696cc000633897 Mon Sep 17 00:00:00 2001
|
|
From: Yangbo Lu <yangbo.lu@nxp.com>
|
|
Date: Mon, 2 Mar 2020 13:46:39 +0800
|
|
Subject: [PATCH] Revert "drm/imx: Revert a patch which merges imx-drm-core and
|
|
ipuv3-crtc in one module"
|
|
|
|
This reverts commit 1e7f3c4066d9afb4bc036b9d4b6f5b18f3c918c7.
|
|
---
|
|
drivers/gpu/drm/imx/Kconfig | 7 -------
|
|
drivers/gpu/drm/imx/Makefile | 4 +---
|
|
drivers/gpu/drm/imx/imx-drm-core.c | 18 +++++++++++++++++-
|
|
drivers/gpu/drm/imx/imx-drm.h | 2 ++
|
|
drivers/gpu/drm/imx/ipuv3-crtc.c | 8 +-------
|
|
5 files changed, 21 insertions(+), 18 deletions(-)
|
|
|
|
--- a/drivers/gpu/drm/imx/Kconfig
|
|
+++ b/drivers/gpu/drm/imx/Kconfig
|
|
@@ -33,13 +33,6 @@ config DRM_IMX_LDB
|
|
Choose this to enable the internal LVDS Display Bridge (LDB)
|
|
found on i.MX53 and i.MX6 processors.
|
|
|
|
-config DRM_IMX_IPUV3
|
|
- tristate
|
|
- depends on DRM_IMX
|
|
- depends on IMX_IPUV3_CORE
|
|
- default y if DRM_IMX=y
|
|
- default m if DRM_IMX=m
|
|
-
|
|
config DRM_IMX_HDMI
|
|
tristate "Freescale i.MX DRM HDMI"
|
|
select DRM_DW_HDMI
|
|
--- a/drivers/gpu/drm/imx/Makefile
|
|
+++ b/drivers/gpu/drm/imx/Makefile
|
|
@@ -1,6 +1,6 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
|
|
-imxdrm-objs := imx-drm-core.o
|
|
+imxdrm-objs := imx-drm-core.o ipuv3-crtc.o ipuv3-plane.o
|
|
|
|
obj-$(CONFIG_DRM_IMX) += imxdrm.o
|
|
|
|
@@ -8,7 +8,5 @@ obj-$(CONFIG_DRM_IMX_PARALLEL_DISPLAY) +
|
|
obj-$(CONFIG_DRM_IMX_TVE) += imx-tve.o
|
|
obj-$(CONFIG_DRM_IMX_LDB) += imx-ldb.o
|
|
|
|
-imx-ipuv3-crtc-objs := ipuv3-crtc.o ipuv3-plane.o
|
|
-obj-$(CONFIG_DRM_IMX_IPUV3) += imx-ipuv3-crtc.o
|
|
obj-$(CONFIG_DRM_IMX_HDMI) += dw_hdmi-imx.o
|
|
obj-$(CONFIG_DRM_IMX_CDNS_MHDP) += cdn-mhdp-imxdrv.o cdn-mhdp-dp-phy.o cdn-mhdp-hdmi-phy.o cdn-mhdp-imx8qm.o cdn-mhdp-ls1028a.o
|
|
--- a/drivers/gpu/drm/imx/imx-drm-core.c
|
|
+++ b/drivers/gpu/drm/imx/imx-drm-core.c
|
|
@@ -361,7 +361,23 @@ static struct platform_driver imx_drm_pd
|
|
.of_match_table = imx_drm_dt_ids,
|
|
},
|
|
};
|
|
-module_platform_driver(imx_drm_pdrv);
|
|
+
|
|
+static struct platform_driver * const drivers[] = {
|
|
+ &imx_drm_pdrv,
|
|
+ &ipu_drm_driver,
|
|
+};
|
|
+
|
|
+static int __init imx_drm_init(void)
|
|
+{
|
|
+ return platform_register_drivers(drivers, ARRAY_SIZE(drivers));
|
|
+}
|
|
+module_init(imx_drm_init);
|
|
+
|
|
+static void __exit imx_drm_exit(void)
|
|
+{
|
|
+ platform_unregister_drivers(drivers, ARRAY_SIZE(drivers));
|
|
+}
|
|
+module_exit(imx_drm_exit);
|
|
|
|
MODULE_AUTHOR("Sascha Hauer <s.hauer@pengutronix.de>");
|
|
MODULE_DESCRIPTION("i.MX drm driver core");
|
|
--- a/drivers/gpu/drm/imx/imx-drm.h
|
|
+++ b/drivers/gpu/drm/imx/imx-drm.h
|
|
@@ -28,6 +28,8 @@ int imx_drm_init_drm(struct platform_dev
|
|
int preferred_bpp);
|
|
int imx_drm_exit_drm(void);
|
|
|
|
+extern struct platform_driver ipu_drm_driver;
|
|
+
|
|
void imx_drm_mode_config_init(struct drm_device *drm);
|
|
|
|
struct drm_gem_cma_object *imx_drm_fb_get_obj(struct drm_framebuffer *fb);
|
|
--- a/drivers/gpu/drm/imx/ipuv3-crtc.c
|
|
+++ b/drivers/gpu/drm/imx/ipuv3-crtc.c
|
|
@@ -492,16 +492,10 @@ static int ipu_drm_remove(struct platfor
|
|
return 0;
|
|
}
|
|
|
|
-static struct platform_driver ipu_drm_driver = {
|
|
+struct platform_driver ipu_drm_driver = {
|
|
.driver = {
|
|
.name = "imx-ipuv3-crtc",
|
|
},
|
|
.probe = ipu_drm_probe,
|
|
.remove = ipu_drm_remove,
|
|
};
|
|
-module_platform_driver(ipu_drm_driver);
|
|
-
|
|
-MODULE_AUTHOR("Sascha Hauer <s.hauer@pengutronix.de>");
|
|
-MODULE_DESCRIPTION(DRIVER_DESC);
|
|
-MODULE_LICENSE("GPL");
|
|
-MODULE_ALIAS("platform:imx-ipuv3-crtc");
|