mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
cddd459140
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
From 047bb6ca46d7cd8b2400bfbf062469ff84cec3d3 Mon Sep 17 00:00:00 2001
|
|
From: Camelia Groza <camelia.groza@nxp.com>
|
|
Date: Fri, 20 Dec 2019 16:01:23 +0200
|
|
Subject: [PATCH] sdk_dpaa: ceetm: enable building as a module
|
|
|
|
Enable building the driver as a module by adding the required module
|
|
macros and creating the fsl_ceetm object file.
|
|
|
|
Signed-off-by: Camelia Groza <camelia.groza@nxp.com>
|
|
---
|
|
drivers/net/ethernet/freescale/sdk_dpaa/Makefile | 4 +++-
|
|
drivers/net/ethernet/freescale/sdk_dpaa/dpaa_eth_ceetm.c | 2 ++
|
|
2 files changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
--- a/drivers/net/ethernet/freescale/sdk_dpaa/Makefile
|
|
+++ b/drivers/net/ethernet/freescale/sdk_dpaa/Makefile
|
|
@@ -17,9 +17,11 @@ endif
|
|
ifeq ($(CONFIG_FSL_DPAA_1588),y)
|
|
fsl_dpa-objs += dpaa_1588.o
|
|
endif
|
|
+
|
|
ifeq ($(CONFIG_FSL_DPAA_CEETM),y)
|
|
ccflags-y += -I$(srctree)/drivers/net/ethernet/freescale/sdk_fman/src/wrapper
|
|
-fsl_dpa-objs += dpaa_eth_ceetm.o
|
|
+obj-$(CONFIG_FSL_SDK_DPAA_ETH) += fsl_ceetm.o
|
|
+fsl_ceetm-objs += dpaa_eth_ceetm.o
|
|
endif
|
|
|
|
fsl_mac-objs += mac.o mac-api.o
|
|
--- a/drivers/net/ethernet/freescale/sdk_dpaa/dpaa_eth_ceetm.c
|
|
+++ b/drivers/net/ethernet/freescale/sdk_dpaa/dpaa_eth_ceetm.c
|
|
@@ -33,6 +33,8 @@
|
|
#include "dpaa_eth_ceetm.h"
|
|
|
|
#define DPA_CEETM_DESCRIPTION "FSL DPAA CEETM qdisc"
|
|
+MODULE_LICENSE("Dual BSD/GPL");
|
|
+MODULE_DESCRIPTION(DPA_CEETM_DESCRIPTION);
|
|
|
|
const struct nla_policy ceetm_policy[TCA_CEETM_MAX + 1] = {
|
|
[TCA_CEETM_COPT] = { .len = sizeof(struct tc_ceetm_copt) },
|