mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
c60dd7bef9
The patches in the ath79 target have not been sorted for a long time and they are very chaotic now. This patch sorts them again according to the OpenWrt naming rules[1], so that we can better manage them. [1] https://openwrt.org/docs/guide-developer/toolchain/use-patches-with-buildsystem#naming_patches Signed-off-by: Shiji Yang <yangshiji66@qq.com>
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: ar71xx: ar934x_nfc: experimental NAND Flash Controller driver for AR934x
|
|
|
|
SVN-Revision: 33385
|
|
---
|
|
drivers/mtd/nand/raw/Kconfig | 8 ++++++++
|
|
drivers/mtd/nand/raw/Makefile | 1 +
|
|
2 files changed, 9 insertions(+)
|
|
|
|
--- a/drivers/mtd/nand/raw/Kconfig
|
|
+++ b/drivers/mtd/nand/raw/Kconfig
|
|
@@ -555,4 +555,12 @@ config MTD_NAND_DISKONCHIP_BBTWRITE
|
|
load time (assuming you build diskonchip as a module) with the module
|
|
parameter "inftl_bbt_write=1".
|
|
|
|
+config MTD_NAND_AR934X
|
|
+ tristate "Support for NAND controller on Qualcomm Atheros AR934x/QCA955x SoCs"
|
|
+ depends on ATH79 || COMPILE_TEST
|
|
+ depends on HAS_IOMEM
|
|
+ help
|
|
+ Enables support for NAND controller on Qualcomm Atheros SoCs.
|
|
+ This controller is found on AR934x and QCA955x SoCs.
|
|
+
|
|
endif # MTD_RAW_NAND
|
|
--- a/drivers/mtd/nand/raw/Makefile
|
|
+++ b/drivers/mtd/nand/raw/Makefile
|
|
@@ -58,6 +58,7 @@ obj-$(CONFIG_MTD_NAND_ARASAN) += arasan
|
|
obj-$(CONFIG_MTD_NAND_INTEL_LGM) += intel-nand-controller.o
|
|
obj-$(CONFIG_MTD_NAND_ROCKCHIP) += rockchip-nand-controller.o
|
|
obj-$(CONFIG_MTD_NAND_PL35X) += pl35x-nand-controller.o
|
|
+obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nand.o
|
|
|
|
nand-objs := nand_base.o nand_legacy.o nand_bbt.o nand_timings.o nand_ids.o
|
|
nand-objs += nand_onfi.o
|