mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-21 03:55:06 +00:00
toolchain: Update GCC 9 to version 9.3.0
The removed patch is included in GCC 9.3.0. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
db70077668
commit
cb44ab4f5d
@ -14,7 +14,7 @@ config GCC_VERSION
|
||||
string
|
||||
default "5.5.0" if GCC_VERSION_5
|
||||
default "7.5.0" if GCC_VERSION_7
|
||||
default "9.2.0" if GCC_VERSION_9
|
||||
default "9.3.0" if GCC_VERSION_9
|
||||
default "8.4.0"
|
||||
|
||||
config GCC_USE_IREMAP
|
||||
|
@ -40,8 +40,8 @@ ifeq ($(PKG_VERSION),8.4.0)
|
||||
PKG_HASH:=e30a6e52d10e1f27ed55104ad233c30bd1e99cfb5ff98ab022dc941edd1b2dd4
|
||||
endif
|
||||
|
||||
ifeq ($(PKG_VERSION),9.2.0)
|
||||
PKG_HASH:=ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206
|
||||
ifeq ($(PKG_VERSION),9.3.0)
|
||||
PKG_HASH:=71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
|
||||
endif
|
||||
|
||||
PATCH_DIR=../patches/$(GCC_VERSION)
|
||||
|
@ -1,55 +0,0 @@
|
||||
From d57faea9337ad595d005687247c3322252f70ba1 Mon Sep 17 00:00:00 2001
|
||||
From: rsandifo <rsandifo@138bc75d-0d04-0410-961f-82ee72b054a4>
|
||||
Date: Sun, 7 Jul 2019 09:49:14 +0000
|
||||
Subject: [PATCH] Fix uninitialised use in mips_split_move
|
||||
|
||||
While testing the fix for PR91068, I hit an rtl checking failure
|
||||
while building newlib. mips_split_move was decomposing an address that
|
||||
happened to be symbolic and then tried to access the REGNO of the base
|
||||
register field, which wasn't initialised but which by chance pointed to
|
||||
valid memory.
|
||||
|
||||
2019-07-07 Richard Sandiford <richard.sandiford@arm.com>
|
||||
|
||||
gcc/
|
||||
* config/mips/mips.c (mips_split_move): Zero-initialize addr
|
||||
and check whether addr.reg is nonnull before using it.
|
||||
|
||||
|
||||
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@273174 138bc75d-0d04-0410-961f-82ee72b054a4
|
||||
---
|
||||
gcc/ChangeLog | 5 +++++
|
||||
gcc/config/mips/mips.c | 4 ++--
|
||||
2 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/gcc/ChangeLog
|
||||
+++ b/gcc/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
+2019-07-07 Richard Sandiford <richard.sandiford@arm.com>
|
||||
+
|
||||
+ * config/mips/mips.c (mips_split_move): Zero-initialize addr
|
||||
+ and check whether addr.reg is nonnull before using it.
|
||||
+
|
||||
2019-08-12 Release Manager
|
||||
|
||||
* GCC 9.2.0 released.
|
||||
--- a/gcc/config/mips/mips.c
|
||||
+++ b/gcc/config/mips/mips.c
|
||||
@@ -4849,7 +4849,7 @@ mips_split_move (rtx dest, rtx src, enum
|
||||
can forward SRC for DEST. This is most useful if the next insn is a
|
||||
simple store. */
|
||||
rtx_insn *insn = (rtx_insn *)insn_;
|
||||
- struct mips_address_info addr;
|
||||
+ struct mips_address_info addr = {};
|
||||
if (insn)
|
||||
{
|
||||
rtx_insn *next = next_nonnote_nondebug_insn_bb (insn);
|
||||
@@ -4862,7 +4862,7 @@ mips_split_move (rtx dest, rtx src, enum
|
||||
{
|
||||
rtx tmp = XEXP (src, 0);
|
||||
mips_classify_address (&addr, tmp, GET_MODE (tmp), true);
|
||||
- if (REGNO (addr.reg) != REGNO (dest))
|
||||
+ if (addr.reg && REGNO (addr.reg) != REGNO (dest))
|
||||
validate_change (next, &SET_SRC (set), src, false);
|
||||
}
|
||||
else
|
@ -12,7 +12,7 @@ Date: Tue Feb 26 16:16:33 2013 +0000
|
||||
|
||||
--- a/gcc/Makefile.in
|
||||
+++ b/gcc/Makefile.in
|
||||
@@ -3202,18 +3202,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
||||
@@ -3203,18 +3203,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
||||
doc/gccint.info: $(TEXI_GCCINT_FILES)
|
||||
doc/cppinternals.info: $(TEXI_CPPINT_FILES)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/gcc/config/rs6000/rs6000.c
|
||||
+++ b/gcc/config/rs6000/rs6000.c
|
||||
@@ -24365,7 +24365,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||
@@ -24474,7 +24474,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||
/* Define cutoff for using out-of-line functions to save registers. */
|
||||
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
||||
{
|
@ -114,7 +114,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||
; On SVR4 targets, it also controls whether or not to emit a
|
||||
--- a/gcc/doc/invoke.texi
|
||||
+++ b/gcc/doc/invoke.texi
|
||||
@@ -7657,6 +7657,17 @@ This option is only supported for C and
|
||||
@@ -7666,6 +7666,17 @@ This option is only supported for C and
|
||||
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
|
||||
@option{-Wno-pointer-sign}.
|
||||
|
Loading…
Reference in New Issue
Block a user