mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
toolchain: Update GCC 8 to version 8.4.0
The removed patch is included in GCC 8.4.0. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
d33200824f
commit
db70077668
@ -15,7 +15,7 @@ config GCC_VERSION
|
||||
default "5.5.0" if GCC_VERSION_5
|
||||
default "7.5.0" if GCC_VERSION_7
|
||||
default "9.2.0" if GCC_VERSION_9
|
||||
default "8.3.0"
|
||||
default "8.4.0"
|
||||
|
||||
config GCC_USE_IREMAP
|
||||
bool
|
||||
|
@ -36,8 +36,8 @@ ifeq ($(PKG_VERSION),7.5.0)
|
||||
PKG_HASH:=b81946e7f01f90528a1f7352ab08cc602b9ccc05d4e44da4bd501c5a189ee661
|
||||
endif
|
||||
|
||||
ifeq ($(PKG_VERSION),8.3.0)
|
||||
PKG_HASH:=64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c
|
||||
ifeq ($(PKG_VERSION),8.4.0)
|
||||
PKG_HASH:=e30a6e52d10e1f27ed55104ad233c30bd1e99cfb5ff98ab022dc941edd1b2dd4
|
||||
endif
|
||||
|
||||
ifeq ($(PKG_VERSION),9.2.0)
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 045e60da05ec1d4997864883143a951f152cfc9f Mon Sep 17 00:00:00 2001
|
||||
From: jakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>
|
||||
Date: Tue, 30 Apr 2019 20:37:12 +0000
|
||||
Subject: [PATCH] Backported from mainline 2019-03-05 Jakub
|
||||
Jelinek <jakub@redhat.com>
|
||||
|
||||
PR target/89587
|
||||
* config/rs6000/t-linux (MULTIARCH_DIRNAME): Set to non-empty only
|
||||
if_multiarch.
|
||||
|
||||
|
||||
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-8-branch@270720 138bc75d-0d04-0410-961f-82ee72b054a4
|
||||
---
|
||||
gcc/ChangeLog | 4 ++++
|
||||
gcc/config/rs6000/t-linux | 2 +-
|
||||
2 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gcc/config/rs6000/t-linux b/gcc/config/rs6000/t-linux
|
||||
index acfde1f48aec..aeb7440c4920 100644
|
||||
--- a/gcc/config/rs6000/t-linux
|
||||
+++ b/gcc/config/rs6000/t-linux
|
||||
@@ -4,7 +4,7 @@ ifeq (,$(filter $(with_cpu),$(SOFT_FLOAT_CPUS))$(findstring soft,$(with_float)))
|
||||
ifneq (,$(findstring powerpc64,$(target)))
|
||||
MULTILIB_OSDIRNAMES := .=../lib64$(call if_multiarch,:powerpc64-linux-gnu)
|
||||
else
|
||||
-MULTIARCH_DIRNAME := powerpc-linux-gnu
|
||||
+MULTIARCH_DIRNAME := $(call if_multiarch,powerpc-linux-gnu)
|
||||
endif
|
||||
ifneq (,$(findstring powerpcle,$(target)))
|
||||
MULTIARCH_DIRNAME := $(subst -linux,le-linux,$(MULTIARCH_DIRNAME))
|
@ -12,7 +12,7 @@ Date: Tue Feb 26 16:16:33 2013 +0000
|
||||
|
||||
--- a/gcc/Makefile.in
|
||||
+++ b/gcc/Makefile.in
|
||||
@@ -3203,18 +3203,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
||||
@@ -3204,18 +3204,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
||||
doc/gccint.info: $(TEXI_GCCINT_FILES)
|
||||
doc/cppinternals.info: $(TEXI_CPPINT_FILES)
|
||||
|
@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
|
||||
--- a/gcc/config/mips/mips.c
|
||||
+++ b/gcc/config/mips/mips.c
|
||||
@@ -19834,7 +19834,7 @@ mips_option_override (void)
|
||||
@@ -19847,7 +19847,7 @@ mips_option_override (void)
|
||||
flag_pcc_struct_return = 0;
|
||||
|
||||
/* Decide which rtx_costs structure to use. */
|
@ -1,6 +1,6 @@
|
||||
--- a/gcc/config/rs6000/rs6000.c
|
||||
+++ b/gcc/config/rs6000/rs6000.c
|
||||
@@ -24632,7 +24632,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||
@@ -24780,7 +24780,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||
/* Define cutoff for using out-of-line functions to save registers. */
|
||||
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
||||
{
|
@ -114,7 +114,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||
; On SVR4 targets, it also controls whether or not to emit a
|
||||
--- a/gcc/opts.c
|
||||
+++ b/gcc/opts.c
|
||||
@@ -2065,6 +2065,9 @@ common_handle_option (struct gcc_options
|
||||
@@ -2073,6 +2073,9 @@ common_handle_option (struct gcc_options
|
||||
opts, opts_set, loc, dc);
|
||||
break;
|
||||
|
||||
@ -126,7 +126,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||
opts->x_warn_larger_than = value != -1;
|
||||
--- a/gcc/doc/invoke.texi
|
||||
+++ b/gcc/doc/invoke.texi
|
||||
@@ -7014,6 +7014,17 @@ This option is only supported for C and
|
||||
@@ -7013,6 +7013,17 @@ This option is only supported for C and
|
||||
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
|
||||
@option{-Wno-pointer-sign}.
|
||||
|
@ -48,7 +48,7 @@ sellcey@mips.com
|
||||
|
||||
--- a/gcc/config/mips/mips.c
|
||||
+++ b/gcc/config/mips/mips.c
|
||||
@@ -22627,6 +22627,9 @@ mips_starting_frame_offset (void)
|
||||
@@ -22640,6 +22640,9 @@ mips_starting_frame_offset (void)
|
||||
#undef TARGET_STARTING_FRAME_OFFSET
|
||||
#define TARGET_STARTING_FRAME_OFFSET mips_starting_frame_offset
|
||||
|
Loading…
Reference in New Issue
Block a user