mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
kernel: bump 4.19 to 4.19.50
Refreshed all patches. Compile-tested on: cns3xxx, imx6 Runtime-tested on: cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
a7e68927d0
commit
11b4d29ef5
@ -8,11 +8,11 @@ endif
|
||||
|
||||
LINUX_VERSION-4.9 = .181
|
||||
LINUX_VERSION-4.14 = .125
|
||||
LINUX_VERSION-4.19 = .48
|
||||
LINUX_VERSION-4.19 = .50
|
||||
|
||||
LINUX_KERNEL_HASH-4.9.181 = 8fcd223e11cba322801bc38cdb8b581d64c0115f585dcb6604de8561b574fced
|
||||
LINUX_KERNEL_HASH-4.14.125 = 3e3dbc20215a28385bf46e2d0b8d9019df38ef1ee677e5e8870c7c3cde2ab318
|
||||
LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
|
||||
LINUX_KERNEL_HASH-4.19.50 = a9987423918abd20ee68d6e9b14b7225eaca8a586bf75fb56c49f6e1e47ce01e
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
||||
|
@ -23,7 +23,7 @@ produce a noisy warning.
|
||||
xhci->quirks |= XHCI_RESET_ON_RESUME;
|
||||
--- a/drivers/usb/host/xhci.c
|
||||
+++ b/drivers/usb/host/xhci.c
|
||||
@@ -424,10 +424,14 @@ static int xhci_try_enable_msi(struct us
|
||||
@@ -422,10 +422,14 @@ static int xhci_try_enable_msi(struct us
|
||||
free_irq(hcd->irq, hcd);
|
||||
hcd->irq = 0;
|
||||
|
||||
|
@ -208,7 +208,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
|
||||
#include <asm/bootinfo.h>
|
||||
#include <asm/idle.h>
|
||||
@@ -305,6 +306,11 @@ void __init plat_time_init(void)
|
||||
@@ -311,6 +312,11 @@ void __init plat_time_init(void)
|
||||
mips_hpt_frequency = cpu_clk_rate / 2;
|
||||
}
|
||||
|
||||
|
@ -944,7 +944,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
|
||||
#define ATH79_SYS_TYPE_LEN 64
|
||||
|
||||
@@ -230,25 +229,21 @@ void __init plat_mem_setup(void)
|
||||
@@ -236,25 +235,21 @@ void __init plat_mem_setup(void)
|
||||
else if (fw_passed_dtb)
|
||||
__dt_setup_arch((void *)KSEG0ADDR(fw_passed_dtb));
|
||||
|
||||
@ -979,7 +979,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
{
|
||||
struct device_node *np;
|
||||
struct clk *clk;
|
||||
@@ -278,66 +273,12 @@ static void __init ath79_of_plat_time_in
|
||||
@@ -284,66 +279,12 @@ static void __init ath79_of_plat_time_in
|
||||
clk_put(clk);
|
||||
}
|
||||
|
||||
|
@ -40,7 +40,7 @@ it on BCM4708 family.
|
||||
/* called during probe() after chip reset completes */
|
||||
--- a/drivers/usb/host/xhci.c
|
||||
+++ b/drivers/usb/host/xhci.c
|
||||
@@ -158,6 +158,49 @@ int xhci_start(struct xhci_hcd *xhci)
|
||||
@@ -156,6 +156,49 @@ int xhci_start(struct xhci_hcd *xhci)
|
||||
return ret;
|
||||
}
|
||||
|
||||
@ -90,7 +90,7 @@ it on BCM4708 family.
|
||||
/*
|
||||
* Reset a halted HC.
|
||||
*
|
||||
@@ -605,10 +648,20 @@ static int xhci_init(struct usb_hcd *hcd
|
||||
@@ -603,10 +646,20 @@ static int xhci_init(struct usb_hcd *hcd
|
||||
|
||||
static int xhci_run_finished(struct xhci_hcd *xhci)
|
||||
{
|
||||
@ -114,7 +114,7 @@ it on BCM4708 family.
|
||||
xhci->shared_hcd->state = HC_STATE_RUNNING;
|
||||
xhci->cmd_ring_state = CMD_RING_STATE_RUNNING;
|
||||
|
||||
@@ -618,6 +671,10 @@ static int xhci_run_finished(struct xhci
|
||||
@@ -616,6 +669,10 @@ static int xhci_run_finished(struct xhci
|
||||
xhci_dbg_trace(xhci, trace_xhci_dbg_init,
|
||||
"Finished xhci_run for USB3 roothub");
|
||||
return 0;
|
||||
|
@ -71,9 +71,6 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
||||
create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
create mode 100644 net/sched/act_ctinfo.c
|
||||
|
||||
diff --git a/include/net/tc_act/tc_ctinfo.h b/include/net/tc_act/tc_ctinfo.h
|
||||
new file mode 100644
|
||||
index 000000000000..d6a688571672
|
||||
--- /dev/null
|
||||
+++ b/include/net/tc_act/tc_ctinfo.h
|
||||
@@ -0,0 +1,28 @@
|
||||
@ -105,8 +102,6 @@ index 000000000000..d6a688571672
|
||||
+#define to_ctinfo(a) ((struct tcf_ctinfo *)a)
|
||||
+
|
||||
+#endif /* __NET_TC_CTINFO_H */
|
||||
diff --git a/include/uapi/linux/pkt_cls.h b/include/uapi/linux/pkt_cls.h
|
||||
index be382fb0592d..71e10c5a96a0 100644
|
||||
--- a/include/uapi/linux/pkt_cls.h
|
||||
+++ b/include/uapi/linux/pkt_cls.h
|
||||
@@ -68,7 +68,8 @@ enum {
|
||||
@ -119,9 +114,6 @@ index be382fb0592d..71e10c5a96a0 100644
|
||||
};
|
||||
|
||||
#define TCA_ID_MAX __TCA_ID_MAX
|
||||
diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
new file mode 100644
|
||||
index 000000000000..da803e05a89b
|
||||
--- /dev/null
|
||||
+++ b/include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
@@ -0,0 +1,34 @@
|
||||
@ -159,8 +151,6 @@ index 000000000000..da803e05a89b
|
||||
+};
|
||||
+
|
||||
+#endif
|
||||
diff --git a/net/sched/Kconfig b/net/sched/Kconfig
|
||||
index e95741388311..1d79d5dba6e4 100644
|
||||
--- a/net/sched/Kconfig
|
||||
+++ b/net/sched/Kconfig
|
||||
@@ -866,6 +866,23 @@ config NET_ACT_CONNMARK
|
||||
@ -187,8 +177,6 @@ index e95741388311..1d79d5dba6e4 100644
|
||||
config NET_ACT_SKBMOD
|
||||
tristate "skb data modification action"
|
||||
depends on NET_CLS_ACT
|
||||
diff --git a/net/sched/Makefile b/net/sched/Makefile
|
||||
index f0403f49edcb..bb3c2bc44af7 100644
|
||||
--- a/net/sched/Makefile
|
||||
+++ b/net/sched/Makefile
|
||||
@@ -21,6 +21,7 @@ obj-$(CONFIG_NET_ACT_CSUM) += act_csum.o
|
||||
@ -199,9 +187,6 @@ index f0403f49edcb..bb3c2bc44af7 100644
|
||||
obj-$(CONFIG_NET_ACT_SKBMOD) += act_skbmod.o
|
||||
obj-$(CONFIG_NET_ACT_IFE) += act_ife.o
|
||||
obj-$(CONFIG_NET_IFE_SKBMARK) += act_meta_mark.o
|
||||
diff --git a/net/sched/act_ctinfo.c b/net/sched/act_ctinfo.c
|
||||
new file mode 100644
|
||||
index 000000000000..8975cb4976aa
|
||||
--- /dev/null
|
||||
+++ b/net/sched/act_ctinfo.c
|
||||
@@ -0,0 +1,395 @@
|
||||
@ -600,8 +585,6 @@ index 000000000000..8975cb4976aa
|
||||
+MODULE_AUTHOR("Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>");
|
||||
+MODULE_DESCRIPTION("Connection tracking mark actions");
|
||||
+MODULE_LICENSE("GPL");
|
||||
diff --git a/tools/testing/selftests/tc-testing/config b/tools/testing/selftests/tc-testing/config
|
||||
index 203302065458..9d1fddcfb887 100644
|
||||
--- a/tools/testing/selftests/tc-testing/config
|
||||
+++ b/tools/testing/selftests/tc-testing/config
|
||||
@@ -37,6 +37,7 @@ CONFIG_NET_ACT_SKBEDIT=m
|
||||
@ -612,6 +595,3 @@ index 203302065458..9d1fddcfb887 100644
|
||||
CONFIG_NET_ACT_CONNMARK=m
|
||||
CONFIG_NET_ACT_SKBMOD=m
|
||||
CONFIG_NET_ACT_IFE=m
|
||||
--
|
||||
2.20.1 (Apple Git-117)
|
||||
|
||||
|
@ -3518,6 +3518,7 @@ CONFIG_NMI_LOG_BUF_SHIFT=13
|
||||
# CONFIG_NOP_USB_XCEIV is not set
|
||||
# CONFIG_NORTEL_HERMES is not set
|
||||
# CONFIG_NOTIFIER_ERROR_INJECTION is not set
|
||||
# CONFIG_NOUVEAU_LEGACY_CTX_SUPPORT is not set
|
||||
# CONFIG_NOZOMI is not set
|
||||
# CONFIG_NO_BOOTMEM is not set
|
||||
# CONFIG_NO_HZ is not set
|
||||
|
@ -58,7 +58,7 @@
|
||||
|
||||
--- a/include/linux/compiler_types.h
|
||||
+++ b/include/linux/compiler_types.h
|
||||
@@ -264,8 +264,7 @@ struct ftrace_likely_data {
|
||||
@@ -268,8 +268,7 @@ struct ftrace_likely_data {
|
||||
* of extern inline functions at link time.
|
||||
* A lot of inline functions can cause havoc with function tracing.
|
||||
*/
|
||||
|
@ -12,8 +12,6 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
|
||||
arch/powerpc/Kconfig | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig
|
||||
index a80669209155..f1e9f31ee3b0 100644
|
||||
--- a/arch/powerpc/Kconfig
|
||||
+++ b/arch/powerpc/Kconfig
|
||||
@@ -197,7 +197,7 @@ config PPC
|
||||
@ -25,6 +23,3 @@ index a80669209155..f1e9f31ee3b0 100644
|
||||
select HAVE_KPROBES
|
||||
select HAVE_KPROBES_ON_FTRACE
|
||||
select HAVE_KRETPROBES
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
@ -17,11 +17,9 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
|
||||
arch/powerpc/platforms/85xx/Makefile | 1 +
|
||||
4 files changed, 20 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
|
||||
index 25e3184f11f7..0826346fd97c 100644
|
||||
--- a/arch/powerpc/boot/Makefile
|
||||
+++ b/arch/powerpc/boot/Makefile
|
||||
@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S
|
||||
@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
|
||||
src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
|
||||
src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
|
||||
src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
|
||||
@ -29,7 +27,7 @@ index 25e3184f11f7..0826346fd97c 100644
|
||||
|
||||
src-wlib := $(sort $(src-wlib-y))
|
||||
src-plat := $(sort $(src-plat-y))
|
||||
@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm8555
|
||||
@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm
|
||||
image-$(CONFIG_TQM8560) += cuImage.tqm8560
|
||||
image-$(CONFIG_SBC8548) += cuImage.sbc8548
|
||||
image-$(CONFIG_KSI8560) += cuImage.ksi8560
|
||||
@ -38,8 +36,6 @@ index 25e3184f11f7..0826346fd97c 100644
|
||||
# Board ports in arch/powerpc/platform/86xx/Kconfig
|
||||
image-$(CONFIG_MVME7100) += dtbImage.mvme7100
|
||||
|
||||
diff --git a/arch/powerpc/boot/wrapper b/arch/powerpc/boot/wrapper
|
||||
index f9141eaec6ff..bd55094d9899 100755
|
||||
--- a/arch/powerpc/boot/wrapper
|
||||
+++ b/arch/powerpc/boot/wrapper
|
||||
@@ -302,6 +302,11 @@ adder875-redboot)
|
||||
@ -54,8 +50,6 @@ index f9141eaec6ff..bd55094d9899 100755
|
||||
simpleboot-virtex405-*)
|
||||
platformo="$object/virtex405-head.o $object/simpleboot.o $object/virtex.o"
|
||||
binary=y
|
||||
diff --git a/arch/powerpc/platforms/85xx/Kconfig b/arch/powerpc/platforms/85xx/Kconfig
|
||||
index 68920d42b4bc..2bf6533ce023 100644
|
||||
--- a/arch/powerpc/platforms/85xx/Kconfig
|
||||
+++ b/arch/powerpc/platforms/85xx/Kconfig
|
||||
@@ -170,6 +170,18 @@ config STX_GP3
|
||||
@ -77,11 +71,9 @@ index 68920d42b4bc..2bf6533ce023 100644
|
||||
config TQM8540
|
||||
bool "TQ Components TQM8540"
|
||||
help
|
||||
diff --git a/arch/powerpc/platforms/85xx/Makefile b/arch/powerpc/platforms/85xx/Makefile
|
||||
index d1dd0dca5ebf..d0dab29a33eb 100644
|
||||
--- a/arch/powerpc/platforms/85xx/Makefile
|
||||
+++ b/arch/powerpc/platforms/85xx/Makefile
|
||||
@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
|
||||
@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += coren
|
||||
obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o
|
||||
obj-$(CONFIG_STX_GP3) += stx_gp3.o
|
||||
obj-$(CONFIG_TQM85xx) += tqm85xx.o
|
||||
@ -89,6 +81,3 @@ index d1dd0dca5ebf..d0dab29a33eb 100644
|
||||
obj-$(CONFIG_SBC8548) += sbc8548.o
|
||||
obj-$(CONFIG_PPA8548) += ppa8548.o
|
||||
obj-$(CONFIG_SOCRATES) += socrates.o socrates_fpga_pic.o
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user