mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
43e14a2f9e
Since v4.13, iproute2 switched to a config.mk file with greater use of pkg-config for library/feature detection. Replace the old Config patch with one modifying the configure script but enabling the same changes: - explicitly disable TC_CONFIG_ATM - rely on feature detection for IP_CONFIG_SETNS and TC_CONFIG_XT Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
13 lines
328 B
Diff
13 lines
328 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -32,7 +32,8 @@ int main(int argc, char **argv) {
|
|
}
|
|
EOF
|
|
|
|
- if $CC -I$INCLUDE -o $TMPDIR/atmtest $TMPDIR/atmtest.c -latm >/dev/null 2>&1; then
|
|
+# OpenWrt: disable ATM support even if present on host system
|
|
+ if [ 1 -eq 0 ]; then
|
|
echo "TC_CONFIG_ATM:=y" >>$CONFIG
|
|
echo yes
|
|
else
|