mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
45ac906c64
The most affecting change is move of files from bcm4908/ to the bcmbca/. That required updating few paths. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
63 lines
1.7 KiB
Diff
63 lines
1.7 KiB
Diff
From 72e0bdb6d7edb1785d58f2e8e7c80e1d2f93a319 Mon Sep 17 00:00:00 2001
|
|
From: William Zhang <william.zhang@broadcom.com>
|
|
Date: Wed, 3 Aug 2022 10:54:51 -0700
|
|
Subject: [PATCH] arm64: dts: Add BCM4908 generic board dts
|
|
|
|
Add generic bare bone bcm94908.dts file to support any 4908 based
|
|
design. It supports cpu subsystem, memory and an uart console. This can
|
|
be useful for board bring-up and cpu subsystem and memory related kernel
|
|
test as well.
|
|
|
|
Signed-off-by: William Zhang <william.zhang@broadcom.com>
|
|
Link: https://lore.kernel.org/r/20220803175455.47638-6-william.zhang@broadcom.com
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm64/boot/dts/broadcom/bcmbca/Makefile | 1 +
|
|
.../boot/dts/broadcom/bcmbca/bcm94908.dts | 30 +++++++++++++++++++
|
|
2 files changed, 31 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcmbca/bcm94908.dts
|
|
|
|
--- a/arch/arm64/boot/dts/broadcom/bcmbca/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcmbca/Makefile
|
|
@@ -4,6 +4,7 @@ dtb-$(CONFIG_ARCH_BCMBCA) += \
|
|
bcm4906-tplink-archer-c2300-v1.dtb \
|
|
bcm4908-asus-gt-ac5300.dtb \
|
|
bcm4908-netgear-raxe500.dtb \
|
|
+ bcm94908.dtb \
|
|
bcm4912-asus-gt-ax6000.dtb \
|
|
bcm94912.dtb \
|
|
bcm963158.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcmbca/bcm94908.dts
|
|
@@ -0,0 +1,30 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
+/*
|
|
+ * Copyright 2022 Broadcom Ltd.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm4908.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Broadcom BCM94908 Reference Board";
|
|
+ compatible = "brcm,bcm94908", "brcm,bcm4908", "brcm,bcmbca";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ memory@0 {
|
|
+ device_type = "memory";
|
|
+ reg = <0x0 0x0 0x0 0x08000000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ status = "okay";
|
|
+};
|