mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
28cec43807
Compiles faster, is PIC by default, and does not have pkgconfig files with wrong paths. Add various fixes to it as it seems cross compilation was never tested. Signed-off-by: Rosen Penev <rosenp@gmail.com>
21 lines
633 B
Diff
21 lines
633 B
Diff
From e0c1a86bf88b568a7afe8ebaea1b9f84afb892c2 Mon Sep 17 00:00:00 2001
|
|
From: Eli Schwartz <eschwartz@archlinux.org>
|
|
Date: Wed, 4 May 2022 23:52:31 -0400
|
|
Subject: [PATCH] meson: get the project version from the version-gen script
|
|
|
|
This matches autotools and ensures that the version number is actually
|
|
reliable.
|
|
---
|
|
meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1,5 +1,5 @@
|
|
project('util-linux', 'c',
|
|
- version : '2.37',
|
|
+ version : run_command('tools/git-version-gen', check: true).stdout(),
|
|
license : 'GPLv2+')
|
|
|
|
pkgconfig = import('pkgconfig')
|