mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 14:37:57 +00:00
28cec43807
Compiles faster, is PIC by default, and does not have pkgconfig files with wrong paths. Add various fixes to it as it seems cross compilation was never tested. Signed-off-by: Rosen Penev <rosenp@gmail.com>
32 lines
877 B
Diff
32 lines
877 B
Diff
From cd23a4336f49ba6a12ade557a09589f2a7c966f4 Mon Sep 17 00:00:00 2001
|
|
From: Rosen Penev <rosenp@gmail.com>
|
|
Date: Mon, 2 May 2022 16:18:33 -0700
|
|
Subject: [PATCH] meson: make libcap-ng dependent on setpriv
|
|
|
|
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
---
|
|
meson.build | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -334,7 +334,8 @@ have = cc.has_function(
|
|
conf.set('HAVE_CRYPT_ACTIVATE_BY_SIGNED_KEY', have ? 1 : false)
|
|
|
|
lib_cap_ng = dependency(
|
|
- 'libcap-ng')
|
|
+ 'libcap-ng',
|
|
+ required : get_option('build-setpriv'))
|
|
|
|
lib_selinux = dependency(
|
|
'libselinux',
|
|
@@ -1754,7 +1755,7 @@ if opt and not is_disabler(exe)
|
|
exes += exe
|
|
endif
|
|
|
|
-opt = not get_option('build-setpriv').disabled()
|
|
+opt = not get_option('build-setpriv').disabled() and lib_cap_ng.found()
|
|
exe = executable(
|
|
'setpriv',
|
|
setpriv_sources,
|