mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
52a82ce3dd
This just copies the files from the kernel 4.14 specific folders into the kernel 4.19 specific folder, no changes are done to the files in this commit. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
23 lines
830 B
Diff
23 lines
830 B
Diff
From: Felix Fietkau <nbd@nbd.name>
|
|
Subject: mips: use -mno-branch-likely for kernel and userspace
|
|
|
|
saves ~11k kernel size after lzma and ~12k squashfs size in the
|
|
|
|
lede-commit: 41a039f46450ffae9483d6216422098669da2900
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
arch/mips/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -90,7 +90,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
|
|
# machines may also. Since BFD is incredibly buggy with respect to
|
|
# crossformat linking we rely on the elf2ecoff tool for format conversion.
|
|
#
|
|
-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
|
+cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
|
|
cflags-y += -msoft-float
|
|
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
|
|
KBUILD_AFLAGS_MODULE += -mlong-calls
|