mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 06:33:41 +00:00
f1f97db627
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
From 0b000cbfe0aa0323bffa855ef8449c0687a4c071 Mon Sep 17 00:00:00 2001
|
|
From: INAGAKI Hiroshi <musashino.open@gmail.com>
|
|
Date: Thu, 6 May 2021 19:30:58 +0900
|
|
Subject: realtek: backport spi-realtek-rtl driver from 5.12 to 5.10
|
|
|
|
This patch backports "spi-realtek-rtl" driver to Kernel 5.10 from 5.12.
|
|
"MACH_REALTEK_RTL" is used as a platform name in upstream, but "RTL838X"
|
|
is used in OpenWrt, so update the dependency by the additional patch.
|
|
|
|
Submitted-by: INAGAKI Hiroshi <musashino.open@gmail.com>
|
|
---
|
|
drivers/spi/Makefile | 2 +-
|
|
1 files changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -94,7 +94,7 @@ obj-$(CONFIG_SPI_QCOM_QSPI) += spi-qcom
|
|
obj-$(CONFIG_SPI_QUP) += spi-qup.o
|
|
obj-$(CONFIG_SPI_ROCKCHIP) += spi-rockchip.o
|
|
obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
|
|
-obj-$(CONFIG_MACH_REALTEK_RTL) += spi-realtek-rtl.o
|
|
+obj-$(CONFIG_RTL83XX) += spi-realtek-rtl.o
|
|
obj-$(CONFIG_SPI_RPCIF) += spi-rpc-if.o
|
|
obj-$(CONFIG_SPI_RSPI) += spi-rspi.o
|
|
obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
|