mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-01 11:36:49 +00:00
bad01d4806
Removed because they are upstream: generic/pending-5.15/110-v6.3-0001-spidev-Add-Silicon-Labs-EM3581-device-compatible.patch https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=bff165a3993683daddf3f00563960e7675966f91 ipq807x/patches-5.15/0004-v5.16-arm64-dts-qcom-msm8996-Move-clock-cells-to-QMP-PHY-c.patch https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=32f0e52f16d45d743b473659329f93d4a27c68bf Manually adapted: bcm27xx/patches-5.15/950-0040-spi-spidev-Completely-disable-the-spidev-warning.patch bcm27xx/patches-5.15/950-0578-spi-spidev-Restore-loading-from-Device-Tree.patch generic/pending-5.15/110-v6.3-0002-spidev-Add-Silicon-Labs-SI3210-device-compatible.patch Adapt kernel configuration for newly added option CONFIG_ARM64_ERRATUM_3194386. The leddev_list_lock attribute changed from rwlock_t to spinlock_t in: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=590304b798a3b89e716b6b564f8ad14bc9373d93 Link: https://github.com/openwrt/openwrt/pull/16366 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
93 lines
2.9 KiB
Diff
93 lines
2.9 KiB
Diff
From e3692cb2fcd5ba1244512a0f43b8118f65f1c375 Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Sat, 8 Jul 2017 08:20:43 +0200
|
|
Subject: debloat: dmabuf
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
drivers/base/Kconfig | 2 +-
|
|
drivers/dma-buf/Makefile | 10 +++++++---
|
|
drivers/dma-buf/dma-buf.c | 4 +++-
|
|
kernel/sched/core.c | 1 +
|
|
4 files changed, 12 insertions(+), 5 deletions(-)
|
|
|
|
--- a/drivers/base/Kconfig
|
|
+++ b/drivers/base/Kconfig
|
|
@@ -187,7 +187,7 @@ config SOC_BUS
|
|
source "drivers/base/regmap/Kconfig"
|
|
|
|
config DMA_SHARED_BUFFER
|
|
- bool
|
|
+ tristate
|
|
default n
|
|
select IRQ_WORK
|
|
help
|
|
--- a/drivers/dma-buf/heaps/Makefile
|
|
+++ b/drivers/dma-buf/heaps/Makefile
|
|
@@ -1,3 +1,3 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
-obj-$(CONFIG_DMABUF_HEAPS_SYSTEM) += system_heap.o
|
|
-obj-$(CONFIG_DMABUF_HEAPS_CMA) += cma_heap.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_HEAPS_SYSTEM) += system_heap.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_HEAPS_CMA) += cma_heap.o
|
|
--- a/drivers/dma-buf/Makefile
|
|
+++ b/drivers/dma-buf/Makefile
|
|
@@ -1,16 +1,20 @@
|
|
# SPDX-License-Identifier: GPL-2.0-only
|
|
-obj-y := dma-buf.o dma-fence.o dma-fence-array.o dma-fence-chain.o \
|
|
+obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
|
|
+
|
|
+dma-buf-objs-y := dma-buf.o dma-fence.o dma-fence-array.o dma-fence-chain.o \
|
|
dma-resv.o seqno-fence.o
|
|
-obj-$(CONFIG_DMABUF_HEAPS) += dma-heap.o
|
|
-obj-$(CONFIG_DMABUF_HEAPS) += heaps/
|
|
-obj-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
-obj-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
-obj-$(CONFIG_UDMABUF) += udmabuf.o
|
|
-obj-$(CONFIG_DMABUF_SYSFS_STATS) += dma-buf-sysfs-stats.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_HEAPS) += dma-heap.o
|
|
+obj-$(CONFIG_DMABUF_HEAPS) += heaps/
|
|
+dma-buf-objs-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
+dma-buf-objs-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
+dma-buf-objs-$(CONFIG_UDMABUF) += udmabuf.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_SYSFS_STATS) += udmabuf.o
|
|
|
|
dmabuf_selftests-y := \
|
|
selftest.o \
|
|
st-dma-fence.o \
|
|
st-dma-fence-chain.o
|
|
|
|
-obj-$(CONFIG_DMABUF_SELFTESTS) += dmabuf_selftests.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_SELFTESTS) += dmabuf_selftests.o
|
|
+
|
|
+dma-shared-buffer-objs := $(dma-buf-objs-y)
|
|
--- a/drivers/dma-buf/dma-buf.c
|
|
+++ b/drivers/dma-buf/dma-buf.c
|
|
@@ -1513,4 +1513,5 @@ static void __exit dma_buf_deinit(void)
|
|
kern_unmount(dma_buf_mnt);
|
|
dma_buf_uninit_sysfs_statistics();
|
|
}
|
|
-__exitcall(dma_buf_deinit);
|
|
+module_exit(dma_buf_deinit);
|
|
+MODULE_LICENSE("GPL");
|
|
--- a/kernel/sched/core.c
|
|
+++ b/kernel/sched/core.c
|
|
@@ -4217,6 +4217,7 @@ int wake_up_state(struct task_struct *p,
|
|
{
|
|
return try_to_wake_up(p, state, 0);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(wake_up_state);
|
|
|
|
/*
|
|
* Perform scheduler related setup for a newly forked process p.
|
|
--- a/fs/d_path.c
|
|
+++ b/fs/d_path.c
|
|
@@ -316,6 +316,7 @@ char *dynamic_dname(struct dentry *dentr
|
|
buffer += buflen - sz;
|
|
return memcpy(buffer, temp, sz);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(dynamic_dname);
|
|
|
|
char *simple_dname(struct dentry *dentry, char *buffer, int buflen)
|
|
{
|