mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
4b950bc5f4
Changelog: - https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.10.4 - https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.11.0 - https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.11.1 - https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.11.2 - https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.11.3 Fixes: CVE-2023-28484 CVE-2023-29469 Signed-off-by: Nick Hainke <vincent@systemli.org>
13 lines
472 B
Diff
13 lines
472 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -469,6 +469,9 @@ if(LIBXML2_WITH_PROGRAMS)
|
|
add_executable(LibXml2::${PROGRAM} ALIAS ${PROGRAM})
|
|
target_compile_definitions(${PROGRAM} PRIVATE SYSCONFDIR="${CMAKE_INSTALL_FULL_SYSCONFDIR}")
|
|
target_link_libraries(${PROGRAM} LibXml2)
|
|
+ if(LIBXML2_WITH_ICONV AND NOT Iconv_IS_BUILT_IN)
|
|
+ target_link_libraries(${PROGRAM} iconv)
|
|
+ endif()
|
|
if(HAVE_LIBHISTORY)
|
|
target_link_libraries(${PROGRAM} history)
|
|
endif()
|