mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
fa75a3a935
Add patch to fix host-build of the mkimage tool without CONFIG_TOOLS_LIBCRYPTO. Update and refresh all patches. Tested on BananaPi R64 (MT7622) successfully booting from SD card, eMMC and SPI-NAND. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
12 lines
288 B
Diff
12 lines
288 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1061,7 +1061,7 @@ quiet_cmd_pad_cat = CAT $@
|
|
cmd_pad_cat = $(cmd_objcopy) && $(append) || { rm -f $@; false; }
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
-cmd_lzma = lzma -c -z -k -9 $< > $@
|
|
+cmd_lzma = xz --format=lzma -c -z -k -9 $< > $@
|
|
|
|
cfg: u-boot.cfg
|
|
|