mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 01:28:59 +00:00
2ae1330a22
Support for iptables action has been dropped. Remove tc-mod-iptables and related patch (175-reduce-dynamic-syms.patch). We also add the missing libbpf dependency for `ss` since iproute 8740ca9 ("ss: add support for BPF socket-local storage") now means that `ss` requires libbpf as well. Fix 170-ip_tiny.patch, as the help text didn't match all the included functions. Drop upstreamed patches 402-bpf-fix-warning-from-basename.patch and 403-bpf-include-libgen.h-for-basename.patch. All other patches automatically rebased. Co-authored-by: Rany Hany <rany_hany@riseup.net> Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> Signed-off-by: Rany Hany <rany_hany@riseup.net>
13 lines
288 B
Diff
13 lines
288 B
Diff
--- a/tc/Makefile
|
|
+++ b/tc/Makefile
|
|
@@ -107,6 +107,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
|
|
ifneq ($(IPT_LIB_DIR),)
|
|
CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
|
|
endif
|
|
+ifneq ($(XT_LIB_DIR),)
|
|
+ CFLAGS += -DXT_LIB_DIR=\"$(XT_LIB_DIR)\"
|
|
+endif
|
|
|
|
LEX := flex
|
|
CFLAGS += -DYY_NO_INPUT
|