mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
106 lines
4.7 KiB
Diff
106 lines
4.7 KiB
Diff
From cad8f63047c0691e8185d3c9c6a2705b83310c9c Mon Sep 17 00:00:00 2001
|
|
From: Jonas Gorski <jonas.gorski@gmail.com>
|
|
Date: Mon, 31 Jul 2017 20:10:36 +0200
|
|
Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
|
|
|
|
---
|
|
arch/mips/bcm63xx/clk.c | 15 +++++++++++++++
|
|
1 file changed, 15 insertions(+)
|
|
|
|
--- a/arch/mips/bcm63xx/clk.c
|
|
+++ b/arch/mips/bcm63xx/clk.c
|
|
@@ -503,6 +503,8 @@ static struct clk_lookup bcm3368_clks[]
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fff8c100.serial", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fff8c120.serial", "refclk", &clk_periph),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enet0", &clk_enet0),
|
|
CLKDEV_INIT(NULL, "enet1", &clk_enet1),
|
|
@@ -519,7 +521,9 @@ static struct clk_lookup bcm6318_clks[]
|
|
/* fixed rate clocks */
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000100.serial", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx-hsspi.0", "pll", &clk_hsspi_pll),
|
|
+ CLKDEV_INIT("10003000.spi", "pll", &clk_hsspi_pll),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
|
|
CLKDEV_INIT(NULL, "usbh", &clk_usbh),
|
|
@@ -533,7 +537,10 @@ static struct clk_lookup bcm6328_clks[]
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000100.serial", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000120.serial", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx-hsspi.0", "pll", &clk_hsspi_pll),
|
|
+ CLKDEV_INIT("10001000.spi", "pll", &clk_hsspi_pll),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
|
|
CLKDEV_INIT(NULL, "usbh", &clk_usbh),
|
|
@@ -546,6 +553,7 @@ static struct clk_lookup bcm6338_clks[]
|
|
/* fixed rate clocks */
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fffe0300.serial", "refclk", &clk_periph),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enet0", &clk_enet0),
|
|
CLKDEV_INIT(NULL, "enet1", &clk_enet1),
|
|
@@ -560,6 +568,7 @@ static struct clk_lookup bcm6345_clks[]
|
|
/* fixed rate clocks */
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fffe0300.serial", "refclk", &clk_periph),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enet0", &clk_enet0),
|
|
CLKDEV_INIT(NULL, "enet1", &clk_enet1),
|
|
@@ -574,6 +583,7 @@ static struct clk_lookup bcm6348_clks[]
|
|
/* fixed rate clocks */
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fffe0300.serial", "refclk", &clk_periph),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enet0", &clk_enet0),
|
|
CLKDEV_INIT(NULL, "enet1", &clk_enet1),
|
|
@@ -590,6 +600,8 @@ static struct clk_lookup bcm6358_clks[]
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fffe0100.serial", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("fffe0120.serial", "refclk", &clk_periph),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enet0", &clk_enet0),
|
|
CLKDEV_INIT(NULL, "enet1", &clk_enet1),
|
|
@@ -609,7 +621,10 @@ static struct clk_lookup bcm6362_clks[]
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000100.serial", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000120.serial", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx-hsspi.0", "pll", &clk_hsspi_pll),
|
|
+ CLKDEV_INIT("10001000.spi", "pll", &clk_hsspi_pll),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
|
|
CLKDEV_INIT(NULL, "usbh", &clk_usbh),
|
|
@@ -625,6 +640,8 @@ static struct clk_lookup bcm6368_clks[]
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000100.serial", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000120.serial", "refclk", &clk_periph),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
|
|
CLKDEV_INIT(NULL, "usbh", &clk_usbh),
|
|
@@ -639,7 +656,10 @@ static struct clk_lookup bcm63268_clks[]
|
|
CLKDEV_INIT(NULL, "periph", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("10000180.serial", "refclk", &clk_periph),
|
|
+ CLKDEV_INIT("100001a0.serial", "refclk", &clk_periph),
|
|
CLKDEV_INIT("bcm63xx-hsspi.0", "pll", &clk_hsspi_pll),
|
|
+ CLKDEV_INIT("10001000.spi", "pll", &clk_hsspi_pll),
|
|
/* gated clocks */
|
|
CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
|
|
CLKDEV_INIT(NULL, "usbh", &clk_usbh),
|