mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 23:12:32 +00:00
879e68eafd
Switched to upstream tarballs. Switched to libcxxabi as using libsupc++ is quite wonky. Fixed description. Removed patches. The fixes are cosmetic. Added ssp patch. This one is needed for i386 and powerpc under musl. Compile tested every C++ package in the tree with the exception of several boost packages. There's something broken with boost. Ran tested with gerbera. Signed-off-by: Rosen Penev <rosenp@gmail.com>
14 lines
364 B
Diff
14 lines
364 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -760,6 +760,10 @@ function(cxx_link_system_libraries targe
|
|
target_link_libraries(${target} PRIVATE atomic)
|
|
endif()
|
|
|
|
+ if (LIBCXX_HAS_MUSL_LIBC)
|
|
+ target_link_libraries(${target} PRIVATE ssp_nonshared)
|
|
+ endif()
|
|
+
|
|
if (MINGW)
|
|
target_link_libraries(${target} PRIVATE "${MINGW_LIBRARIES}")
|
|
endif()
|