mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-15 01:10:29 +00:00
1e41de2f48
Converts the TP-Link WDR4900 v1 to use the simpleImage in the hopes of prolonging the life of the device. While at it, the patch makes the fdt.bin an ARTIFACT and sets the KERNEL_SIZE to 2684 KiB as a precaution since the stock u-boot is using a fixed kernel size. Note: Give the image some time, it will take much longer to extract and boot. [tested for 4.14/4.19] Signed-off-by: Christian Lamparter <chunkeey@gmail.com> Co-authored-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
95 lines
3.4 KiB
Diff
95 lines
3.4 KiB
Diff
From 1d9f596e572917772b87a2a37e1680902964782f Mon Sep 17 00:00:00 2001
|
|
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Date: Wed, 20 Feb 2013 08:40:33 +0100
|
|
Subject: [PATCH] powerpc: 85xx: add support for the TP-Link TL-WDR4900 v1
|
|
board
|
|
|
|
This patch adds support for the TP-Link TL-WDR4900 v1
|
|
concurrent dual-band wireless router. The devices uses
|
|
the Freescale P1014 SoC.
|
|
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
|
|
---
|
|
arch/powerpc/boot/Makefile | 3 ++-
|
|
arch/powerpc/boot/wrapper | 5 +++++
|
|
arch/powerpc/platforms/85xx/Kconfig | 12 ++++++++++++
|
|
arch/powerpc/platforms/85xx/Makefile | 1 +
|
|
4 files changed, 20 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
|
|
index 25e3184f11f7..0826346fd97c 100644
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S
|
|
src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
|
|
src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
|
|
src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
|
|
+src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
|
|
|
|
src-wlib := $(sort $(src-wlib-y))
|
|
src-plat := $(sort $(src-plat-y))
|
|
@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm8555
|
|
image-$(CONFIG_TQM8560) += cuImage.tqm8560
|
|
image-$(CONFIG_SBC8548) += cuImage.sbc8548
|
|
image-$(CONFIG_KSI8560) += cuImage.ksi8560
|
|
-
|
|
+image-$(CONFIG_TL_WDR4900_V1) += simpleImage.tl-wdr4900-v1
|
|
# Board ports in arch/powerpc/platform/86xx/Kconfig
|
|
image-$(CONFIG_MVME7100) += dtbImage.mvme7100
|
|
|
|
diff --git a/arch/powerpc/boot/wrapper b/arch/powerpc/boot/wrapper
|
|
index f9141eaec6ff..bd55094d9899 100755
|
|
--- a/arch/powerpc/boot/wrapper
|
|
+++ b/arch/powerpc/boot/wrapper
|
|
@@ -302,6 +302,11 @@ adder875-redboot)
|
|
platformo="$object/fixed-head.o $object/redboot-8xx.o"
|
|
binary=y
|
|
;;
|
|
+simpleboot-tl-wdr4900-v1)
|
|
+ platformo="$object/fixed-head.o $object/simpleboot.o"
|
|
+ link_address='0x1000000'
|
|
+ binary=y
|
|
+ ;;
|
|
simpleboot-virtex405-*)
|
|
platformo="$object/virtex405-head.o $object/simpleboot.o $object/virtex.o"
|
|
binary=y
|
|
diff --git a/arch/powerpc/platforms/85xx/Kconfig b/arch/powerpc/platforms/85xx/Kconfig
|
|
index 68920d42b4bc..2bf6533ce023 100644
|
|
--- a/arch/powerpc/platforms/85xx/Kconfig
|
|
+++ b/arch/powerpc/platforms/85xx/Kconfig
|
|
@@ -170,6 +170,18 @@ config STX_GP3
|
|
select CPM2
|
|
select DEFAULT_UIMAGE
|
|
|
|
+config TL_WDR4900_V1
|
|
+ bool "TP-Link TL-WDR4900 v1"
|
|
+ select DEFAULT_UIMAGE
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select GPIO_MPC8XXX
|
|
+ select SWIOTLB
|
|
+ help
|
|
+ This option enables support for the TP-Link TL-WDR4900 v1 board.
|
|
+
|
|
+ This board is a Concurrent Dual-Band wireless router with a
|
|
+ Freescale P1014 SoC.
|
|
+
|
|
config TQM8540
|
|
bool "TQ Components TQM8540"
|
|
help
|
|
diff --git a/arch/powerpc/platforms/85xx/Makefile b/arch/powerpc/platforms/85xx/Makefile
|
|
index d1dd0dca5ebf..d0dab29a33eb 100644
|
|
--- a/arch/powerpc/platforms/85xx/Makefile
|
|
+++ b/arch/powerpc/platforms/85xx/Makefile
|
|
@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
|
|
obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o
|
|
obj-$(CONFIG_STX_GP3) += stx_gp3.o
|
|
obj-$(CONFIG_TQM85xx) += tqm85xx.o
|
|
+obj-$(CONFIG_TL_WDR4900_V1) += tl_wdr4900_v1.o
|
|
obj-$(CONFIG_SBC8548) += sbc8548.o
|
|
obj-$(CONFIG_PPA8548) += ppa8548.o
|
|
obj-$(CONFIG_SOCRATES) += socrates.o socrates_fpga_pic.o
|
|
--
|
|
2.20.1
|
|
|