mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
4f8b350be0
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
91 lines
2.1 KiB
Diff
91 lines
2.1 KiB
Diff
From 5edb8789ba5f9694698386683f2e4e97c70e765a Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Tue, 7 May 2019 14:27:35 +0100
|
|
Subject: [PATCH 499/806] overlays: Delete the deprecated sdio-1bit overlay
|
|
|
|
Use dtoverlay=sdio,bus_width=1,gpios_22_25 instead.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 -
|
|
.../boot/dts/overlays/sdio-1bit-overlay.dts | 63 -------------------
|
|
2 files changed, 64 deletions(-)
|
|
delete mode 100644 arch/arm/boot/dts/overlays/sdio-1bit-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -126,7 +126,6 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
sc16is752-spi1.dtbo \
|
|
sdhost.dtbo \
|
|
sdio.dtbo \
|
|
- sdio-1bit.dtbo \
|
|
sdtweak.dtbo \
|
|
smi.dtbo \
|
|
smi-dev.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/sdio-1bit-overlay.dts
|
|
+++ /dev/null
|
|
@@ -1,63 +0,0 @@
|
|
-/dts-v1/;
|
|
-/plugin/;
|
|
-
|
|
-/* Enable 1-bit SDIO from MMC interface via GPIOs 22-25. Includes sdhost overlay. */
|
|
-
|
|
-/{
|
|
- compatible = "brcm,bcm2708";
|
|
-
|
|
- fragment@0 {
|
|
- target = <&mmc>;
|
|
- __overlay__ {
|
|
- status = "disabled";
|
|
- };
|
|
- };
|
|
-
|
|
- fragment@1 {
|
|
- target = <&soc>;
|
|
- __overlay__ {
|
|
- #address-cells = <1>;
|
|
- #size-cells = <1>;
|
|
-
|
|
- sdio_1bit: sdio@7e300000 {
|
|
- compatible = "brcm,bcm2835-mmc",
|
|
- "brcm,bcm2835-sdhci";
|
|
- reg = <0x7e300000 0x100>;
|
|
- interrupts = <2 30>;
|
|
- clocks = <&clocks 28/*BCM2835_CLOCK_EMMC*/>;
|
|
- dmas = <&dma 11>;
|
|
- dma-names = "rx-tx";
|
|
- brcm,overclock-50 = <0>;
|
|
- status = "okay";
|
|
- pinctrl-names = "default";
|
|
- pinctrl-0 = <&sdio_1bit_pins>;
|
|
- non-removable;
|
|
- bus-width = <1>;
|
|
- };
|
|
- };
|
|
- };
|
|
-
|
|
- fragment@2 {
|
|
- target = <&gpio>;
|
|
- __overlay__ {
|
|
- sdio_1bit_pins: sdio_1bit_pins {
|
|
- brcm,pins = <22 23 24 25>;
|
|
- brcm,function = <7>; /* ALT3 = SD1 */
|
|
- brcm,pull = <0 2 2 2>;
|
|
- };
|
|
- };
|
|
- };
|
|
-
|
|
- fragment@3 {
|
|
- target-path = "/aliases";
|
|
- __overlay__ {
|
|
- mmc1 = "/soc/sdio@7e300000";
|
|
- };
|
|
- };
|
|
-
|
|
-
|
|
- __overrides__ {
|
|
- poll_once = <&sdio_1bit>,"non-removable?";
|
|
- sdio_overclock = <&sdio_1bit>,"brcm,overclock-50:0";
|
|
- };
|
|
-};
|