mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-10 12:51:59 +00:00
This LED controller has a driver under development which is currently being reviewed by the respective kernel maintainers. They are currently on v11 which is included here. The LED1202 is a 12-channel low quiescent current LED driver with: * Supply range from 2.6 V to 5 V * 20 mA current capability per channel * 1.8 V compatible I2C control interface * 8-bit analog dimming individual control * 12-bit local PWM resolution * 8 programmable patterns If the led node is present in the controller then the channel is set to active. The output current can be adjusted separately for each channel by 8-bit analog (current sink input) and 12-bit digital (PWM) dimming control. The LED1202 implements 12 low-side current generators with independent dimming control. Internal volatile memory allows the user to store up to 8 different patterns, each pattern is a particular output configuration in terms of PWM duty-cycle (on 4096 steps). Analog dimming (on 256 steps) is per channel but common to all patterns. Each device tree LED node will have a corresponding entry in /sys/class/leds with the label name. The brightness property corresponds to the per channel analog dimming, while the patterns[1-8] to the PWM dimming control. Signed-off-by: Manuel Fombuena <fombuena@outlook.com> Link: https://github.com/openwrt/openwrt/pull/17451 Signed-off-by: Robert Marko <robimarko@gmail.com>
46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
From 1a5f2263d388016c88d39e141c7eb8085c9313fc Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
Date: Wed, 5 Apr 2023 08:07:00 +0200
|
|
Subject: [PATCH] leds: add support for Sercomm MSP430 LED controller
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Sercomm added an external MSP430G2513 for controlling LEDs through SPI on some
|
|
boards.
|
|
|
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
---
|
|
drivers/leds/Kconfig | 9 +++++++++
|
|
drivers/leds/Makefile | 1 +
|
|
2 files changed, 10 insertions(+)
|
|
|
|
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -299,6 +299,15 @@ config LEDS_COBALT_RAQ
|
|
help
|
|
This option enables support for the Cobalt Raq series LEDs.
|
|
|
|
+config LEDS_SERCOMM_MSP430
|
|
+ tristate "LED support for Sercomm MSP430 SPI LED controllers"
|
|
+ depends on LEDS_CLASS
|
|
+ depends on SPI
|
|
+ depends on OF
|
|
+ help
|
|
+ This option enables support for the Sercomm MSP430G2513 SPI LED
|
|
+ controllers.
|
|
+
|
|
config LEDS_SUNFIRE
|
|
tristate "LED support for SunFire servers."
|
|
depends on LEDS_CLASS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -78,6 +78,7 @@ obj-$(CONFIG_LEDS_POWERNV) += leds-powe
|
|
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
|
|
obj-$(CONFIG_LEDS_SC27XX_BLTC) += leds-sc27xx-bltc.o
|
|
+obj-$(CONFIG_LEDS_SERCOMM_MSP430) += leds-sercomm-msp430.o
|
|
obj-$(CONFIG_LEDS_ST1202) += leds-st1202.o
|
|
obj-$(CONFIG_LEDS_SUNFIRE) += leds-sunfire.o
|
|
obj-$(CONFIG_LEDS_SYSCON) += leds-syscon.o
|