mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 07:22:33 +00:00
442f7406a9
Changelog: https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.15.131
All patches automatically rebased.
Build system: x86_64
Build-tested: ramips/tplink_archer-a6-v3
Run-tested: ramips/tplink_archer-a6-v3
Signed-off-by: John Audia <therealgraysky@proton.me>
(cherry picked from commit 58bb5e147a
)
[Refresh on top of OpenWrt 23.05]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
24 lines
728 B
Diff
24 lines
728 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -96,6 +96,10 @@ config IP17XX_PHY
|
|
tristate "Driver for IC+ IP17xx switches"
|
|
select SWCONFIG
|
|
|
|
+config MVSWITCH_PHY
|
|
+ tristate "Driver for Marvell 88E6060 switches"
|
|
+ select ETHERNET_PACKET_MANGLE
|
|
+
|
|
config PSB6970_PHY
|
|
tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
|
|
select SWCONFIG
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -31,6 +31,7 @@ ar8xxx-y += ar8216.o
|
|
ar8xxx-y += ar8327.o
|
|
obj-$(CONFIG_SWCONFIG_B53) += b53/
|
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
|
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
|
|
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
|
obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
|