openwrt/target/linux/at91/patches-5.15/99-scripts-fix-compilation-error.patch
Claudiu Beznea eb758a8fec at91: kernel v5.15: copy config and patches from 5.10
Copy kernel config and patches from 5.10. Along with it
individual targets' config-default from 5.10 has been moved to
config-5.10.

Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
2022-10-22 00:51:25 +02:00

22 lines
727 B
Diff

From 6d18eaaaff92f928eab6fad2708b6d28785b4872 Mon Sep 17 00:00:00 2001
From: Claudiu Beznea <claudiu.beznea@microchip.com>
Date: Wed, 13 Oct 2021 08:32:07 +0300
Subject: [PATCH] scripts: fix compilation error
Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
---
scripts/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/scripts/Makefile
+++ b/scripts/Makefile
@@ -21,7 +21,7 @@ HOSTCFLAGS_asn1_compiler.o = -I$(srctree
HOSTCFLAGS_sign-file.o = $(CRYPTO_CFLAGS)
HOSTLDLIBS_sign-file = $(CRYPTO_LIBS)
HOSTCFLAGS_extract-cert.o = $(CRYPTO_CFLAGS)
-HOSTLDLIBS_extract-cert = $(CRYPTO_LIBS)
+HOSTLDLIBS_extract-cert = $(CRYPTO_LIBS) -lpthread
ifdef CONFIG_UNWINDER_ORC
ifeq ($(ARCH),x86_64)