mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-01 19:46:51 +00:00
5ecc0cfd6f
Changelog since 5.4.24 mentions CVE-2019-19769, CVE-2020-8648, CVE-2020-8649 and CVE-2020-8647. Removed upstreamed: generic: 507-v5.6-iio-chemical-sps30-fix-missing-triggered-buffer-depe.patch generic: 600-ipv6-addrconf-call-ipv6_mc_up-for-non-Ethernet-inter.patch bcm27xx: 950-0435-ASoC-pcm512x-Fix-unbalanced-regulator-enable-call-in.patch ipq806x: 701-stmmac-fix-notifier-registration.patch lantiq: 002-pinctrl-falcon-fix-syntax-error.patch octeontx: 0002-net-thunderx-workaround-BGX-TX-Underflow-issue.patch Run tested: apu2, qemu-x86-64, apalis, a64-olinuxino, nbg6617 Build tested: sunxi/a53, imx6, x86/64, ipq40xx Tested-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> [apu2] Signed-off-by: Petr Štetiar <ynezz@true.cz>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 7542fb08d2726606057c4283b3a454abb195a0f5 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Mon, 23 Sep 2019 09:26:41 +0100
|
|
Subject: [PATCH] kbuild: Allow .dtbo overlays to be built piecemeal
|
|
|
|
Before 4.20, it was possible to build an arbitrary overlay by copying
|
|
it to arm/boot/dts/overlays/mytest-overlay.dts and running:
|
|
|
|
make ARCH=arm overlays/mytest.dtbo
|
|
|
|
In 4.20 the .dtb build rules were centralised, requiring the dowstream
|
|
.dtbo build rules to be changed. They were, enough to support "make ...
|
|
dtbs", but not sufficiently to allow this ad-hoc, one-off building of
|
|
individual files.
|
|
|
|
Add the missing makefile rule to support this way of building.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3250
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1238,6 +1238,9 @@ ifneq ($(dtstree),)
|
|
%.dtb: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
|
|
+%.dtbo: prepare3 scripts_dtc
|
|
+ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
+
|
|
PHONY += dtbs dtbs_install dtbs_check
|
|
dtbs dtbs_check: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree)
|