mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
9261e7447e
This makes the patches which were just copied in the previous commit apply on top of kernel 4.19. The patches in the backports-4.19 folder were checked if they are really in kernel 4.19 based on the title and only removed if they were found in the upstream kernel. The following additional patches form the pending folder went into upstream Linux 4.19: pending-4.19/171-usb-dwc2-Fix-inefficient-copy-of-unaligned-buffers.patch pending-4.19/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch pending-4.19/478-mtd-spi-nor-Add-support-for-XM25QH64A-and-XM25QH128A.patch pending-4.19/479-mtd-spi-nor-add-eon-en25qh32.patch pending-4.19/950-tty-serial-exar-generalize-rs485-setup.patch pending-4.19/340-MIPS-mm-remove-mips_dma_mapping_error.patch Bigger changes were introduced to the m25p80 spi nor driver, as far as I saw it in the new code, it now has the functionality provided in this patch: pending-4.19/450-mtd-m25p80-allow-fallback-from-spi_flash_read-to-reg.patch Part of this patch went upstream independent of OpenWrt: hack-4.19/220-gc_sections.patch This patch was reworked to match the changes done upstream. The MIPS DMA API changed a lot, this patch was rewritten to match the new DMA handling: pending-4.19/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch I did bigger manual changes to the following patches and I am not 100% sure if they are all correct: pending-4.19/0931-w1-gpio-fix-problem-with-platfom-data-in-w1-gpio.patch pending-4.19/411-mtd-partial_eraseblock_write.patch pending-4.19/600-netfilter_conntrack_flush.patch pending-4.19/611-netfilter_match_bypass_default_table.patch pending-4.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch hack-4.19/211-host_tools_portability.patch hack-4.19/221-module_exports.patch hack-4.19/321-powerpc_crtsavres_prereq.patch hack-4.19/902-debloat_proc.patch This is based on patchset from Marko Ratkaj <marko.ratkaj@sartura.hr> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From 107c0964cb8db7ca28ac5199426414fdab3c274d Mon Sep 17 00:00:00 2001
|
|
From: "Alexandros C. Couloumbis" <alex@ozo.com>
|
|
Date: Fri, 7 Jul 2017 17:14:51 +0200
|
|
Subject: hack: arch: powerpc: drop register save/restore library from modules
|
|
|
|
Upstream GCC uses a libgcc function for saving/restoring registers. This
|
|
makes the code bigger, and upstream kernels need to carry that function
|
|
for every single kernel module. Our GCC is patched to avoid those
|
|
references, so we can drop the extra bloat for modules.
|
|
|
|
lede-commit: e8e1084654f50904e6bf77b70b2de3f137d7b3ec
|
|
Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
|
|
---
|
|
arch/powerpc/Makefile | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -60,20 +60,6 @@ machine-$(CONFIG_PPC64) += 64
|
|
machine-$(CONFIG_CPU_LITTLE_ENDIAN) += le
|
|
UTS_MACHINE := $(subst $(space),,$(machine-y))
|
|
|
|
-# XXX This needs to be before we override LD below
|
|
-ifdef CONFIG_PPC32
|
|
-KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
|
|
-else
|
|
-KBUILD_LDFLAGS_MODULE += -T $(srctree)/arch/powerpc/kernel/module.lds
|
|
-ifeq ($(call ld-ifversion, -ge, 225000000, y),y)
|
|
-# Have the linker provide sfpr if possible.
|
|
-# There is a corresponding test in arch/powerpc/lib/Makefile
|
|
-KBUILD_LDFLAGS_MODULE += --save-restore-funcs
|
|
-else
|
|
-KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
|
|
-endif
|
|
-endif
|
|
-
|
|
ifdef CONFIG_CPU_LITTLE_ENDIAN
|
|
KBUILD_CFLAGS += -mlittle-endian
|
|
KBUILD_LDFLAGS += -EL
|