mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-04 13:04:22 +00:00
9604e216bf
There is no point in keeping the AR40xx driver as a patch as its not pending merge or backport. To allow for easier maintenance until DSA is ready move it into files like EDMA is. Signed-off-by: Robert Marko <robert.marko@sartura.hr> [combine with removal from patches-5.4] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
27 lines
786 B
Diff
27 lines
786 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -587,6 +587,13 @@ config MDIO_IPQ40XX
|
|
This driver supports the MDIO interface found in Qualcomm
|
|
Atheros ipq40xx Soc chip.
|
|
|
|
+config AR40XX_PHY
|
|
+ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
|
|
+ depends on HAS_IOMEM && OF
|
|
+ select SWCONFIG
|
|
+ ---help---
|
|
+ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
|
|
+
|
|
endif # PHYLIB
|
|
|
|
config MICREL_KS8995MA
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -70,6 +70,7 @@ ifdef CONFIG_HWMON
|
|
aquantia-objs += aquantia_hwmon.o
|
|
endif
|
|
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
|
+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
|
|
obj-$(CONFIG_AX88796B_PHY) += ax88796b.o
|
|
obj-$(CONFIG_AT803X_PHY) += at803x.o
|
|
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
|