mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 17:18:59 +00:00
b299002877
Refreshed patches, removed upstreamed patches: oxnas: 003-ARM-dts-oxnas-Fix-clear-mask-property.patch generic: 184-USB-serial-option-add-Wistron-Neweb-D19Q1.patch Run tested: apu2, qemu-x86-64, apalis Build tested: sunxi/a53, imx6, x86/64, ipq40xx Tested-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> [apu2] Signed-off-by: Petr Štetiar <ynezz@true.cz>
24 lines
759 B
Diff
24 lines
759 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -42,6 +42,12 @@ config MDIO_BCM_IPROC
|
|
This module provides a driver for the MDIO busses found in the
|
|
Broadcom iProc SoC's.
|
|
|
|
+config RTL8367S_GSW
|
|
+ tristate "rtl8367 Gigabit Switch support for mt7622"
|
|
+ depends on NET_VENDOR_MEDIATEK
|
|
+ help
|
|
+ This driver supports rtl8367s in mt7622
|
|
+
|
|
config MDIO_BCM_UNIMAC
|
|
tristate "Broadcom UniMAC MDIO bus controller"
|
|
depends on HAS_IOMEM
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -111,4 +111,5 @@ obj-$(CONFIG_TERANETICS_PHY) += teraneti
|
|
obj-$(CONFIG_VITESSE_PHY) += vitesse.o
|
|
obj-$(CONFIG_XILINX_GMII2RGMII) += xilinx_gmii2rgmii.o
|
|
obj-$(CONFIG_MT753X_GSW) += mtk/mt753x/
|
|
+obj-$(CONFIG_RTL8367S_GSW) += rtk/
|
|
|