mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
92b8fe0e0e
Refreshed all patches. Compile-tested on: imx6 Runtime-tested on: imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
56 lines
2.1 KiB
Diff
56 lines
2.1 KiB
Diff
From 4ee213d8c2afeab9a68f8530317260298b4b6b82 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|
Date: Wed, 19 Jun 2019 08:16:33 +0100
|
|
Subject: [PATCH] MIPS: fix build on non-linux hosts
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
calc_vmlinuz_load_addr.c requires SZ_64K to be defined for alignment
|
|
purposes. It included "../../../../include/linux/sizes.h" to define
|
|
that size, however "sizes.h" tries to include <linux/const.h> which
|
|
assumes linux system headers. These may not exist eg. the following
|
|
error was encountered when building Linux for OpenWrt under macOS:
|
|
|
|
In file included from arch/mips/boot/compressed/calc_vmlinuz_load_addr.c:16:
|
|
arch/mips/boot/compressed/../../../../include/linux/sizes.h:11:10: fatal error: 'linux/const.h' file not found
|
|
^~~~~~~~~~
|
|
|
|
Change makefile to force building on local linux headers instead of
|
|
system headers. Also change eye-watering relative reference in include
|
|
file spec.
|
|
|
|
Thanks to Jo-Philip Wich & Petr Štetiar for assistance in tracking this
|
|
down & fixing.
|
|
|
|
Suggested-by: Jo-Philipp Wich <jo@mein.io>
|
|
Signed-off-by: Petr Štetiar <ynezz@true.cz>
|
|
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|
---
|
|
arch/mips/boot/compressed/Makefile | 2 ++
|
|
arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | 2 +-
|
|
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
--- a/arch/mips/boot/compressed/Makefile
|
|
+++ b/arch/mips/boot/compressed/Makefile
|
|
@@ -78,6 +78,8 @@ OBJCOPYFLAGS_piggy.o := --add-section=.i
|
|
$(obj)/piggy.o: $(obj)/dummy.o $(obj)/vmlinux.bin.z FORCE
|
|
$(call if_changed,objcopy)
|
|
|
|
+HOSTCFLAGS_calc_vmlinuz_load_addr.o += $(LINUXINCLUDE)
|
|
+
|
|
# Calculate the load address of the compressed kernel image
|
|
hostprogs-y := calc_vmlinuz_load_addr
|
|
|
|
--- a/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
|
|
+++ b/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
|
|
@@ -13,7 +13,7 @@
|
|
#include <stdint.h>
|
|
#include <stdio.h>
|
|
#include <stdlib.h>
|
|
-#include "../../../../include/linux/sizes.h"
|
|
+#include <linux/sizes.h>
|
|
|
|
int main(int argc, char *argv[])
|
|
{
|