mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-25 00:11:13 +00:00
28cec43807
Compiles faster, is PIC by default, and does not have pkgconfig files with wrong paths. Add various fixes to it as it seems cross compilation was never tested. Signed-off-by: Rosen Penev <rosenp@gmail.com>
22 lines
675 B
Diff
22 lines
675 B
Diff
From e51565b653cf09985df57cb7254b16d5af5df223 Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Caramelli <caramelli.devel@gmail.com>
|
|
Date: Fri, 29 Apr 2022 18:16:36 +0200
|
|
Subject: [PATCH] meson: fix when HAVE_CLOCK_GETTIME is set
|
|
|
|
Signed-off-by: Nicolas Caramelli <caramelli.devel@gmail.com>
|
|
---
|
|
meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -602,7 +602,7 @@ if not have
|
|
have = cc.has_function('clock_gettime',
|
|
dependencies : realtime_libs)
|
|
endif
|
|
-conf.set('HAVE_CLOCK_GETTIME', have_dirfd ? 1 : false)
|
|
+conf.set('HAVE_CLOCK_GETTIME', have ? 1 : false)
|
|
|
|
thread_libs = dependency('threads')
|
|
|