mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-01 11:36:49 +00:00
bad01d4806
Removed because they are upstream: generic/pending-5.15/110-v6.3-0001-spidev-Add-Silicon-Labs-EM3581-device-compatible.patch https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=bff165a3993683daddf3f00563960e7675966f91 ipq807x/patches-5.15/0004-v5.16-arm64-dts-qcom-msm8996-Move-clock-cells-to-QMP-PHY-c.patch https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=32f0e52f16d45d743b473659329f93d4a27c68bf Manually adapted: bcm27xx/patches-5.15/950-0040-spi-spidev-Completely-disable-the-spidev-warning.patch bcm27xx/patches-5.15/950-0578-spi-spidev-Restore-loading-from-Device-Tree.patch generic/pending-5.15/110-v6.3-0002-spidev-Add-Silicon-Labs-SI3210-device-compatible.patch Adapt kernel configuration for newly added option CONFIG_ARM64_ERRATUM_3194386. The leddev_list_lock attribute changed from rwlock_t to spinlock_t in: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=590304b798a3b89e716b6b564f8ad14bc9373d93 Link: https://github.com/openwrt/openwrt/pull/16366 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
48 lines
1.9 KiB
Diff
48 lines
1.9 KiB
Diff
From e84e2430ee0e483842b4ff013ae8a6e7e2fa2734 Mon Sep 17 00:00:00 2001
|
|
From: Weijie Gao <weijie.gao@mediatek.com>
|
|
Date: Wed, 1 Apr 2020 02:07:58 +0800
|
|
Subject: [PATCH 1/2] mtd: rawnand: add driver support for MT7621 nand
|
|
flash controller
|
|
|
|
This patch adds NAND flash controller driver for MediaTek MT7621 SoC.
|
|
|
|
The NAND flash controller is similar with controllers described in
|
|
mtk_nand.c, except that the controller from MT7621 doesn't support DMA
|
|
transmission, and some registers' offset and fields are different.
|
|
|
|
Signed-off-by: Weijie Gao <weijie.gao@mediatek.com>
|
|
---
|
|
drivers/mtd/nand/raw/Kconfig | 8 +
|
|
drivers/mtd/nand/raw/Makefile | 1 +
|
|
drivers/mtd/nand/raw/mt7621_nand.c | 1348 ++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 1357 insertions(+)
|
|
create mode 100644 drivers/mtd/nand/raw/mt7621_nand.c
|
|
|
|
--- a/drivers/mtd/nand/raw/Kconfig
|
|
+++ b/drivers/mtd/nand/raw/Kconfig
|
|
@@ -357,6 +357,14 @@ config MTD_NAND_QCOM
|
|
Enables support for NAND flash chips on SoCs containing the EBI2 NAND
|
|
controller. This controller is found on IPQ806x SoC.
|
|
|
|
+config MTD_NAND_MT7621
|
|
+ tristate "MT7621 NAND controller"
|
|
+ depends on SOC_MT7621 || COMPILE_TEST
|
|
+ depends on HAS_IOMEM
|
|
+ help
|
|
+ Enables support for NAND controller on MT7621 SoC.
|
|
+ This driver uses PIO mode for data transmission instead of DMA mode.
|
|
+
|
|
config MTD_NAND_MTK
|
|
tristate "MTK NAND controller"
|
|
depends on ARCH_MEDIATEK || COMPILE_TEST
|
|
--- a/drivers/mtd/nand/raw/Makefile
|
|
+++ b/drivers/mtd/nand/raw/Makefile
|
|
@@ -48,6 +48,7 @@ obj-$(CONFIG_MTD_NAND_SUNXI) += sunxi_n
|
|
obj-$(CONFIG_MTD_NAND_HISI504) += hisi504_nand.o
|
|
obj-$(CONFIG_MTD_NAND_BRCMNAND) += brcmnand/
|
|
obj-$(CONFIG_MTD_NAND_QCOM) += qcom_nandc.o
|
|
+obj-$(CONFIG_MTD_NAND_MT7621) += mt7621_nand.o
|
|
obj-$(CONFIG_MTD_NAND_MTK) += mtk_ecc.o mtk_nand.o
|
|
obj-$(CONFIG_MTD_NAND_MXIC) += mxic_nand.o
|
|
obj-$(CONFIG_MTD_NAND_TEGRA) += tegra_nand.o
|