mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
ca6885456f
Patch 0061-tty-serial-ar933x-uart-rs485-gpio.patch wasn't included
when adding support for kernel 5.4. Re-add it and refresh patches.
Fixes: 53ab9865c2
("ath79: add support for kernel 5.4")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
26 lines
690 B
Diff
26 lines
690 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -62,6 +62,12 @@ config MTD_MYLOADER_PARTS
|
|
You will still need the parsing functions to be called by the driver
|
|
for your particular device. It won't happen automatically.
|
|
|
|
+config MTD_TPLINK_PARTS
|
|
+ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
|
|
+ depends on ATH79
|
|
+ ---help---
|
|
+ TBD.
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
#
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD) += mtd.o
|
|
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
|
|
|
|
obj-y += parsers/
|
|
+obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
|
|
|
|
obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
|
|
|