mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
fe209fa47d
All patches automatically rebased Build system: x86_64 Build-tested: bcm2711/RPi4B, mt7622/RT3200 Run-tested: bcm2711/RPi4B, mt7622/RT3200 Signed-off-by: John Audia <therealgraysky@proton.me>
30 lines
919 B
Diff
30 lines
919 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -247,6 +247,16 @@ config GPIO_EM
|
|
help
|
|
Say yes here to support GPIO on Renesas Emma Mobile SoCs.
|
|
|
|
+config GPIO_EN7523
|
|
+ tristate "Airoha GPIO support"
|
|
+ depends on ARCH_AIROHA
|
|
+ default ARCH_AIROHA
|
|
+ select GPIO_GENERIC
|
|
+ select GPIOLIB_IRQCHIP
|
|
+ help
|
|
+ Say Y or M here to support the GPIO controller block on the
|
|
+ Airoha EN7523 SoC. It supports two banks of 32 GPIOs.
|
|
+
|
|
config GPIO_EP93XX
|
|
def_bool y
|
|
depends on ARCH_EP93XX
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -57,6 +57,7 @@ obj-$(CONFIG_GPIO_DLN2) += gpio-dln2.o
|
|
obj-$(CONFIG_GPIO_DWAPB) += gpio-dwapb.o
|
|
obj-$(CONFIG_GPIO_EIC_SPRD) += gpio-eic-sprd.o
|
|
obj-$(CONFIG_GPIO_EM) += gpio-em.o
|
|
+obj-$(CONFIG_GPIO_EN7523) += gpio-en7523.o
|
|
obj-$(CONFIG_GPIO_EP93XX) += gpio-ep93xx.o
|
|
obj-$(CONFIG_GPIO_EXAR) += gpio-exar.o
|
|
obj-$(CONFIG_GPIO_F7188X) += gpio-f7188x.o
|