mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
1eebe72a80
Manually rebased: bcm27xx/patches-5.15/950-0600-xhci-quirks-add-link-TRB-quirk-for-VL805.patch bcm27xx/patches-5.15/950-0606-usb-xhci-add-VLI_TRB_CACHE_BUG-quirk.patch bcm27xx/patches-5.15/950-0717-usb-xhci-add-a-quirk-for-Superspeed-bulk-OUT-transfe.patch bcm53xx/patches-5.15/180-usb-xhci-add-support-for-performing-fake-doorbell.patch lantiq/patches-5.15/0028-NET-lantiq-various-etop-fixes.patch All other patches automatically rebased Build system: x86_64 Build-tested: bcm2711/RPi4B, mt7622/RT3200 Run-tested: bcm2711/RPi4B, mt7622/RT3200 Signed-off-by: John Audia <therealgraysky@proton.me>
44 lines
1.6 KiB
Diff
44 lines
1.6 KiB
Diff
From 23147af14531cbdada194b94120ef8774f46292d Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <blogic@openwrt.org>
|
|
Date: Thu, 13 Nov 2014 19:08:40 +0100
|
|
Subject: [PATCH 46/53] mmc: MIPS: ralink: add sdhci for mt7620a SoC
|
|
|
|
Signed-off-by: John Crispin <blogic@openwrt.org>
|
|
---
|
|
drivers/mmc/host/Kconfig | 2 +
|
|
drivers/mmc/host/Makefile | 1 +
|
|
drivers/mmc/host/mtk-mmc/Kconfig | 16 +
|
|
drivers/mmc/host/mtk-mmc/Makefile | 42 +
|
|
drivers/mmc/host/mtk-mmc/board.h | 137 ++
|
|
drivers/mmc/host/mtk-mmc/dbg.c | 347 ++++
|
|
drivers/mmc/host/mtk-mmc/dbg.h | 156 ++
|
|
drivers/mmc/host/mtk-mmc/mt6575_sd.h | 1001 +++++++++++
|
|
drivers/mmc/host/mtk-mmc/sd.c | 3060 ++++++++++++++++++++++++++++++++++
|
|
9 files changed, 4762 insertions(+)
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/Kconfig
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/Makefile
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/board.h
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/dbg.c
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/dbg.h
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/mt6575_sd.h
|
|
create mode 100644 drivers/mmc/host/mtk-mmc/sd.c
|
|
|
|
--- a/drivers/mmc/host/Kconfig
|
|
+++ b/drivers/mmc/host/Kconfig
|
|
@@ -1092,3 +1092,5 @@ config MMC_OWL
|
|
|
|
config MMC_SDHCI_EXTERNAL_DMA
|
|
bool
|
|
+
|
|
+source "drivers/mmc/host/mtk-mmc/Kconfig"
|
|
--- a/drivers/mmc/host/Makefile
|
|
+++ b/drivers/mmc/host/Makefile
|
|
@@ -3,6 +3,7 @@
|
|
# Makefile for MMC/SD host controller drivers
|
|
#
|
|
|
|
+obj-$(CONFIG_MTK_MMC) += mtk-mmc/
|
|
obj-$(CONFIG_MMC_ARMMMCI) += armmmci.o
|
|
armmmci-y := mmci.o
|
|
armmmci-$(CONFIG_MMC_QCOM_DML) += mmci_qcom_dml.o
|