mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 08:51:13 +00:00
21d02e598a
Since commit torvalds/linux@bbc4d71 ("net: phy: realtek: fix rtl8211e rx/tx
delay config") network is broken on the FriendlyELEC(ARM) ZeroPi.
Replaces custom patches with upstream uboot patch:
2527b24f39
Signed-off-by: Arturas Moskvinas <arturas.moskvinas@gmail.com>
149 lines
4.6 KiB
Diff
149 lines
4.6 KiB
Diff
From 2527b24f39d8f27ba2fd922ca27a1f14119cfa1b Mon Sep 17 00:00:00 2001
|
|
From: Yu-Tung Chang <mtwget@gmail.com>
|
|
Date: Sat, 19 Jun 2021 16:16:45 +0800
|
|
Subject: [PATCH] sunxi: h3: Add initial ZeroPi support
|
|
|
|
ZeroPi is a new board of high performance with low cost
|
|
designed by FriendlyElec., using the Allwinner H3 SOC.
|
|
|
|
ZeroPi features
|
|
- Allwinner H3, Quad-core Cortex-A7@1.2GHz
|
|
- 256MB/512MB DDR3 RAM
|
|
- microsd slot
|
|
- 10/100/1000Mbps Ethernet
|
|
- Debug Serial Port
|
|
- DC 5V/2A power-supply
|
|
|
|
Signed-off-by: Yu-Tung Chang <mtwget@gmail.com>
|
|
Reviewed-by: Andre Przywara <andre.przywara@arm.com>
|
|
Signed-off-by: Andre Przywara <andre.przywara@arm.com>
|
|
---
|
|
--- a/arch/arm/dts/Makefile
|
|
+++ b/arch/arm/dts/Makefile
|
|
@@ -560,7 +560,8 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
|
|
sun8i-h3-orangepi-plus.dtb \
|
|
sun8i-h3-orangepi-plus2e.dtb \
|
|
sun8i-h3-orangepi-zero-plus2.dtb \
|
|
- sun8i-h3-rervision-dvk.dtb
|
|
+ sun8i-h3-rervision-dvk.dtb \
|
|
+ sun8i-h3-zeropi.dtb
|
|
dtb-$(CONFIG_MACH_SUN8I_R40) += \
|
|
sun8i-r40-bananapi-m2-ultra.dtb \
|
|
sun8i-v40-bananapi-m2-berry.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm/dts/sun8i-h3-zeropi.dts
|
|
@@ -0,0 +1,85 @@
|
|
+/*
|
|
+ * Copyright (C) 2020 Yu-Tung Chang <mtwget@gmail.com>
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+#include "sun8i-h3-nanopi.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "FriendlyARM ZeroPi";
|
|
+ compatible = "friendlyarm,zeropi", "allwinner,sun8i-h3";
|
|
+
|
|
+ aliases {
|
|
+ ethernet0 = &emac;
|
|
+ };
|
|
+
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <100000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 3 6 GPIO_ACTIVE_HIGH>; /* PD6 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&external_mdio {
|
|
+ ext_rgmii_phy: ethernet-phy@7 {
|
|
+ compatible = "ethernet-phy-ieee802.3-c22";
|
|
+ reg = <7>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&emac_rgmii_pins>;
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ phy-handle = <&ext_rgmii_phy>;
|
|
+ phy-mode = "rgmii-id";
|
|
+
|
|
+ allwinner,leds-active-low;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ status = "okay";
|
|
+ dr_mode = "host";
|
|
+};
|
|
--- a/board/sunxi/MAINTAINERS
|
|
+++ b/board/sunxi/MAINTAINERS
|
|
@@ -508,3 +508,9 @@ YONES TOPTECH BS1078 V2 BOARD
|
|
M: Peter Korsgaard <peter@korsgaard.com>
|
|
S: Maintained
|
|
F: configs/Yones_Toptech_BS1078_V2_defconfig
|
|
+
|
|
+ZEROPI BOARD
|
|
+M: Yu-Tung Chang <mtwget@gmail.com>
|
|
+S: Maintained
|
|
+F: configs/zeropi_defconfig
|
|
+F: arch/arm/dts/sun8i-h3-zeropi.dts
|
|
--- /dev/null
|
|
+++ b/configs/zeropi_defconfig
|
|
@@ -0,0 +1,13 @@
|
|
+CONFIG_ARM=y
|
|
+CONFIG_ARCH_SUNXI=y
|
|
+CONFIG_DEFAULT_DEVICE_TREE="sun8i-h3-zeropi"
|
|
+CONFIG_SPL=y
|
|
+CONFIG_MACH_SUN8I_H3=y
|
|
+CONFIG_DRAM_CLK=408
|
|
+CONFIG_MACPWR="PD6"
|
|
+# CONFIG_VIDEO_DE2 is not set
|
|
+# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
|
|
+CONFIG_CONSOLE_MUX=y
|
|
+CONFIG_SUN8I_EMAC=y
|
|
+CONFIG_USB_EHCI_HCD=y
|
|
+CONFIG_USB_OHCI_HCD=y
|