mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
a937eef305
Copy patches and config from 5.15 kernel version. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From 5e7813e5725d79d00e0988472c306490fc48b3e1 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
Date: Wed, 17 May 2023 18:21:19 +0200
|
|
Subject: [PATCH] pci: add bcm6348-pci support
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
---
|
|
drivers/pci/controller/Kconfig | 5 +++++
|
|
drivers/pci/controller/Makefile | 1 +
|
|
2 files changed, 6 insertions(+)
|
|
|
|
--- a/drivers/pci/controller/Kconfig
|
|
+++ b/drivers/pci/controller/Kconfig
|
|
@@ -3,6 +3,11 @@
|
|
menu "PCI controller drivers"
|
|
depends on PCI
|
|
|
|
+config PCI_BCM6348
|
|
+ bool "BCM6348 PCI controller"
|
|
+ depends on BMIPS_GENERIC || COMPILE_TEST
|
|
+ depends on OF
|
|
+
|
|
config PCIE_BCM6318
|
|
bool "BCM6318 PCIe controller"
|
|
depends on BMIPS_GENERIC || COMPILE_TEST
|
|
--- a/drivers/pci/controller/Makefile
|
|
+++ b/drivers/pci/controller/Makefile
|
|
@@ -1,4 +1,5 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
+obj-$(CONFIG_PCI_BCM6348) += pci-bcm6348.o
|
|
obj-$(CONFIG_PCIE_BCM6318) += pcie-bcm6318.o
|
|
obj-$(CONFIG_PCIE_BCM6328) += pcie-bcm6328.o
|
|
obj-$(CONFIG_PCIE_CADENCE) += cadence/
|