mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
101 lines
2.8 KiB
Diff
101 lines
2.8 KiB
Diff
From 55b3c295a6dd32de589bcd38c771748773e2d0d2 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Sat, 9 Dec 2017 21:45:12 +0000
|
|
Subject: [PATCH 139/454] overlays: Add applepi-dac overlay
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/2302
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 6 ++
|
|
.../boot/dts/overlays/applepi-dac-overlay.dts | 57 +++++++++++++++++++
|
|
3 files changed, 64 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/applepi-dac-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -11,6 +11,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
allo-digione.dtbo \
|
|
allo-piano-dac-pcm512x-audio.dtbo \
|
|
allo-piano-dac-plus-pcm512x-audio.dtbo \
|
|
+ applepi-dac.dtbo \
|
|
at86rf233.dtbo \
|
|
audioinjector-addons.dtbo \
|
|
audioinjector-wm8731-audio.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -337,6 +337,12 @@ Params: 24db_digital_gain Allow ga
|
|
better voice quality. (default Off)
|
|
|
|
|
|
+Name: applepi-dac
|
|
+Info: Configures the Orchard Audio ApplePi-DAC audio card
|
|
+Load: dtoverlay=applepi-dac
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: at86rf233
|
|
Info: Configures the Atmel AT86RF233 802.15.4 low-power WPAN transceiver,
|
|
connected to spi0.0
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/applepi-dac-overlay.dts
|
|
@@ -0,0 +1,57 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&sound>;
|
|
+ __overlay__ {
|
|
+ compatible = "simple-audio-card";
|
|
+ simple-audio-card,name = "ApplePi-DAC";
|
|
+
|
|
+ status = "okay";
|
|
+
|
|
+ playback_link: simple-audio-card,dai-link@1 {
|
|
+ format = "i2s";
|
|
+
|
|
+ p_cpu_dai: cpu {
|
|
+ sound-dai = <&i2s>;
|
|
+ dai-tdm-slot-num = <2>;
|
|
+ dai-tdm-slot-width = <32>;
|
|
+ };
|
|
+
|
|
+ p_codec_dai: codec {
|
|
+ sound-dai = <&codec_out>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ codec_out: pcm1794a-codec {
|
|
+ #sound-dai-cells = <0>;
|
|
+ compatible = "ti,pcm1794a";
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&i2s>;
|
|
+ __overlay__ {
|
|
+ #sound-dai-cells = <0>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+/*
|
|
+ Written by: Leonid Ayzenshtat
|
|
+ Company: Orchard Audio (www.orchardaudio.com)
|
|
+
|
|
+ compile with:
|
|
+ dtc -@ -H epapr -O dtb -o ApplePi-DAC.dtbo -W no-unit_address_vs_reg ApplePi-DAC.dts
|
|
+*/
|