mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
296 lines
8.7 KiB
Diff
296 lines
8.7 KiB
Diff
From e6a023d12a233e5866e716d82aa4dd5464e8e145 Mon Sep 17 00:00:00 2001
|
|
From: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
Date: Thu, 30 Jun 2016 18:38:42 +0100
|
|
Subject: [PATCH 076/454] Add IQAudIO Digi WM8804 board support
|
|
|
|
Support IQAudIO Digi board with iqaudio_digi machine driver and
|
|
iqaudio-digi-wm8804-audio overlay.
|
|
|
|
NB. Machine driver is a cut and paste of hifiberry_digi code, with format
|
|
and general cleanup to comply with kernel coding standards.
|
|
|
|
Signed-off-by: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
---
|
|
sound/soc/bcm/Kconfig | 7 +
|
|
sound/soc/bcm/Makefile | 2 +
|
|
sound/soc/bcm/iqaudio_digi.c | 239 +++++++++++++++++++++++++++++++++++
|
|
3 files changed, 248 insertions(+)
|
|
create mode 100644 sound/soc/bcm/iqaudio_digi.c
|
|
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -81,6 +81,13 @@ config SND_BCM2708_SOC_IQAUDIO_DAC
|
|
help
|
|
Say Y or M if you want to add support for IQaudIO-DAC.
|
|
|
|
+config SND_BCM2708_SOC_IQAUDIO_DIGI
|
|
+ tristate "Support for IQAudIO Digi"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_WM8804
|
|
+ help
|
|
+ Say Y or M if you want to add support for IQAudIO Digital IO board.
|
|
+
|
|
config SND_BCM2708_SOC_RASPIDAC3
|
|
tristate "Support for RaspiDAC Rev.3x"
|
|
depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -19,6 +19,7 @@ snd-soc-justboom-digi-objs := justboom-d
|
|
snd-soc-rpi-dac-objs := rpi-dac.o
|
|
snd-soc-rpi-proto-objs := rpi-proto.o
|
|
snd-soc-iqaudio-dac-objs := iqaudio-dac.o
|
|
+snd-soc-iqaudio-digi-objs := iqaudio_digi.o
|
|
snd-soc-raspidac3-objs := raspidac3.o
|
|
snd-soc-audioinjector-pi-soundcard-objs := audioinjector-pi-soundcard.o
|
|
|
|
@@ -32,6 +33,7 @@ obj-$(CONFIG_SND_BCM2708_SOC_JUSTBOOM_DI
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RPI_DAC) += snd-soc-rpi-dac.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RPI_PROTO) += snd-soc-rpi-proto.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) += snd-soc-iqaudio-dac.o
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DIGI) += snd-soc-iqaudio-digi.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RASPIDAC3) += snd-soc-raspidac3.o
|
|
obj-$(CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD) += snd-soc-audioinjector-pi-soundcard.o
|
|
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/iqaudio_digi.c
|
|
@@ -0,0 +1,239 @@
|
|
+/*
|
|
+ * ASoC Driver for IQAudIO WM8804 Digi
|
|
+ *
|
|
+ * Author: Daniel Matuschek <info@crazy-audio.com>
|
|
+ * based on the HifiBerry DAC driver by Florian Meier <florian.meier@koalo.de>
|
|
+ * Copyright 2013
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+#include "../codecs/wm8804.h"
|
|
+
|
|
+static short int auto_shutdown_output;
|
|
+module_param(auto_shutdown_output, short,
|
|
+ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP);
|
|
+MODULE_PARM_DESC(auto_shutdown_output, "Shutdown SP/DIF output if playback is stopped");
|
|
+
|
|
+static int snd_rpi_iqaudio_digi_init(struct snd_soc_pcm_runtime *rtd)
|
|
+{
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+
|
|
+ /* enable TX output */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x4, 0x0);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int snd_rpi_iqaudio_digi_startup(struct snd_pcm_substream *substream)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+
|
|
+ /* turn on digital output */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x3c, 0x00);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static void snd_rpi_iqaudio_digi_shutdown(struct snd_pcm_substream *substream)
|
|
+{
|
|
+ if (auto_shutdown_output) {
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+
|
|
+ /* turn off digital output */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x3c, 0x3c);
|
|
+ }
|
|
+}
|
|
+
|
|
+
|
|
+static int snd_rpi_iqaudio_digi_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *codec_dai = rtd->codec_dai;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+
|
|
+ int sysclk = 27000000; /* This is fixed on this board */
|
|
+
|
|
+ long mclk_freq = 0;
|
|
+ int mclk_div = 1;
|
|
+ int sampling_freq = 1;
|
|
+
|
|
+ int ret;
|
|
+
|
|
+ int samplerate = params_rate(params);
|
|
+
|
|
+ if (samplerate <= 96000) {
|
|
+ mclk_freq = samplerate * 256;
|
|
+ mclk_div = WM8804_MCLKDIV_256FS;
|
|
+ } else {
|
|
+ mclk_freq = samplerate * 128;
|
|
+ mclk_div = WM8804_MCLKDIV_128FS;
|
|
+ }
|
|
+
|
|
+ switch (samplerate) {
|
|
+ case 32000:
|
|
+ sampling_freq = 0x03;
|
|
+ break;
|
|
+ case 44100:
|
|
+ sampling_freq = 0x00;
|
|
+ break;
|
|
+ case 48000:
|
|
+ sampling_freq = 0x02;
|
|
+ break;
|
|
+ case 88200:
|
|
+ sampling_freq = 0x08;
|
|
+ break;
|
|
+ case 96000:
|
|
+ sampling_freq = 0x0a;
|
|
+ break;
|
|
+ case 176400:
|
|
+ sampling_freq = 0x0c;
|
|
+ break;
|
|
+ case 192000:
|
|
+ sampling_freq = 0x0e;
|
|
+ break;
|
|
+ default:
|
|
+ dev_err(codec->dev, "Failed to set WM8804 SYSCLK, unsupported samplerate %d\n",
|
|
+ samplerate);
|
|
+ }
|
|
+
|
|
+ snd_soc_dai_set_clkdiv(codec_dai, WM8804_MCLK_DIV, mclk_div);
|
|
+ snd_soc_dai_set_pll(codec_dai, 0, 0, sysclk, mclk_freq);
|
|
+
|
|
+ ret = snd_soc_dai_set_sysclk(codec_dai, WM8804_TX_CLKSRC_PLL,
|
|
+ sysclk, SND_SOC_CLOCK_OUT);
|
|
+ if (ret < 0) {
|
|
+ dev_err(codec->dev, "Failed to set WM8804 SYSCLK: %d\n", ret);
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ /* Enable TX output */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x4, 0x0);
|
|
+
|
|
+ /* Power on */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x9, 0);
|
|
+
|
|
+ /* set sampling frequency status bits */
|
|
+ snd_soc_update_bits(codec, WM8804_SPDTX4, 0x0f, sampling_freq);
|
|
+
|
|
+ return snd_soc_dai_set_bclk_ratio(cpu_dai, 64);
|
|
+}
|
|
+
|
|
+/* machine stream operations */
|
|
+static struct snd_soc_ops snd_rpi_iqaudio_digi_ops = {
|
|
+ .hw_params = snd_rpi_iqaudio_digi_hw_params,
|
|
+ .startup = snd_rpi_iqaudio_digi_startup,
|
|
+ .shutdown = snd_rpi_iqaudio_digi_shutdown,
|
|
+};
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_iqaudio_digi_dai[] = {
|
|
+{
|
|
+ .name = "IQAudIO Digi",
|
|
+ .stream_name = "IQAudIO Digi HiFi",
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "wm8804-spdif",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "wm8804.1-003b",
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S |
|
|
+ SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBM_CFM,
|
|
+ .ops = &snd_rpi_iqaudio_digi_ops,
|
|
+ .init = snd_rpi_iqaudio_digi_init,
|
|
+},
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_rpi_iqaudio_digi = {
|
|
+ .name = "IQAudIODigi",
|
|
+ .owner = THIS_MODULE,
|
|
+ .dai_link = snd_rpi_iqaudio_digi_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_iqaudio_digi_dai),
|
|
+};
|
|
+
|
|
+static int snd_rpi_iqaudio_digi_probe(struct platform_device *pdev)
|
|
+{
|
|
+ struct snd_soc_card *card = &snd_rpi_iqaudio_digi;
|
|
+ char *prefix = "wm8804-digi,";
|
|
+ char prop[128];
|
|
+ struct device_node *np;
|
|
+ int ret = 0;
|
|
+
|
|
+ snd_rpi_iqaudio_digi.dev = &pdev->dev;
|
|
+
|
|
+ np = pdev->dev.of_node;
|
|
+ if (np) {
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_iqaudio_digi_dai[0];
|
|
+ struct device_node *i2s_node;
|
|
+
|
|
+ i2s_node = of_parse_phandle(np, "i2s-controller", 0);
|
|
+ if (i2s_node) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_node;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_node;
|
|
+ }
|
|
+
|
|
+ snprintf(prop, sizeof(prop), "%scard-name", prefix);
|
|
+ of_property_read_string(np, prop, &card->name);
|
|
+
|
|
+ snprintf(prop, sizeof(prop), "%sdai-name", prefix);
|
|
+ of_property_read_string(np, prop, &dai->name);
|
|
+
|
|
+ snprintf(prop, sizeof(prop), "%sdai-stream-name", prefix);
|
|
+ of_property_read_string(np, prop, &dai->stream_name);
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(card);
|
|
+ if (ret && ret != -EPROBE_DEFER)
|
|
+ dev_err(&pdev->dev, "snd_soc_register_card() failed: %d\n",
|
|
+ ret);
|
|
+
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+static int snd_rpi_iqaudio_digi_remove(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_unregister_card(&snd_rpi_iqaudio_digi);
|
|
+}
|
|
+
|
|
+static const struct of_device_id snd_rpi_iqaudio_digi_of_match[] = {
|
|
+ { .compatible = "iqaudio,wm8804-digi", },
|
|
+ {},
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, snd_rpi_iqaudio_digi_of_match);
|
|
+
|
|
+static struct platform_driver snd_rpi_iqaudio_digi_driver = {
|
|
+ .driver = {
|
|
+ .name = "IQAudIODigi",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = snd_rpi_iqaudio_digi_of_match,
|
|
+ },
|
|
+ .probe = snd_rpi_iqaudio_digi_probe,
|
|
+ .remove = snd_rpi_iqaudio_digi_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_rpi_iqaudio_digi_driver);
|
|
+
|
|
+MODULE_AUTHOR("Daniel Matuschek <info@crazy-audio.com>");
|
|
+MODULE_DESCRIPTION("ASoC Driver for IQAudIO WM8804 Digi");
|
|
+MODULE_LICENSE("GPL v2");
|