mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
4234d5ec45
Release notes: https://cmake.org/cmake/help/latest/release/3.31.html Refresh patches: - 120-curl-fix-libressl-linking.patch - 130-bootstrap_parallel_make_flag.patch - 150-zstd-libarchive.patch - 160-disable_xcode_generator.patch Signed-off-by: Jack Sun <sunjiazheng321521@gmail.com> Link: https://github.com/openwrt/openwrt/pull/17056 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
23 lines
471 B
Diff
23 lines
471 B
Diff
--- a/Source/CMakeLists.txt
|
|
+++ b/Source/CMakeLists.txt
|
|
@@ -888,7 +888,7 @@ if(CMake_USE_XCOFF_PARSER)
|
|
endif()
|
|
|
|
# Xcode only works on Apple
|
|
-if(APPLE)
|
|
+if(APPLE_DISABLED)
|
|
target_sources(
|
|
CMakeLib
|
|
PRIVATE
|
|
--- a/Source/cmake.cxx
|
|
+++ b/Source/cmake.cxx
|
|
@@ -133,7 +133,7 @@
|
|
# include "cmGlobalGhsMultiGenerator.h"
|
|
#endif
|
|
|
|
-#if defined(__APPLE__)
|
|
+#if defined(__APPLE_DISABLED__)
|
|
# if !defined(CMAKE_BOOTSTRAP)
|
|
# include "cmGlobalXCodeGenerator.h"
|
|
|