mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
9261e7447e
This makes the patches which were just copied in the previous commit apply on top of kernel 4.19. The patches in the backports-4.19 folder were checked if they are really in kernel 4.19 based on the title and only removed if they were found in the upstream kernel. The following additional patches form the pending folder went into upstream Linux 4.19: pending-4.19/171-usb-dwc2-Fix-inefficient-copy-of-unaligned-buffers.patch pending-4.19/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch pending-4.19/478-mtd-spi-nor-Add-support-for-XM25QH64A-and-XM25QH128A.patch pending-4.19/479-mtd-spi-nor-add-eon-en25qh32.patch pending-4.19/950-tty-serial-exar-generalize-rs485-setup.patch pending-4.19/340-MIPS-mm-remove-mips_dma_mapping_error.patch Bigger changes were introduced to the m25p80 spi nor driver, as far as I saw it in the new code, it now has the functionality provided in this patch: pending-4.19/450-mtd-m25p80-allow-fallback-from-spi_flash_read-to-reg.patch Part of this patch went upstream independent of OpenWrt: hack-4.19/220-gc_sections.patch This patch was reworked to match the changes done upstream. The MIPS DMA API changed a lot, this patch was rewritten to match the new DMA handling: pending-4.19/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch I did bigger manual changes to the following patches and I am not 100% sure if they are all correct: pending-4.19/0931-w1-gpio-fix-problem-with-platfom-data-in-w1-gpio.patch pending-4.19/411-mtd-partial_eraseblock_write.patch pending-4.19/600-netfilter_conntrack_flush.patch pending-4.19/611-netfilter_match_bypass_default_table.patch pending-4.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch hack-4.19/211-host_tools_portability.patch hack-4.19/221-module_exports.patch hack-4.19/321-powerpc_crtsavres_prereq.patch hack-4.19/902-debloat_proc.patch This is based on patchset from Marko Ratkaj <marko.ratkaj@sartura.hr> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
193 lines
5.6 KiB
Diff
193 lines
5.6 KiB
Diff
From e3d8676f5722b7622685581e06e8f53e6138e3ab Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Sat, 15 Jul 2017 23:42:36 +0200
|
|
Subject: use -ffunction-sections, -fdata-sections and --gc-sections
|
|
|
|
In combination with kernel symbol export stripping this significantly reduces
|
|
the kernel image size. Used on both ARM and MIPS architectures.
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
Makefile | 10 +++----
|
|
arch/arm/Kconfig | 1 +
|
|
arch/arm/boot/compressed/Makefile | 1 +
|
|
arch/arm/kernel/vmlinux.lds.S | 26 ++++++++--------
|
|
arch/mips/Kconfig | 1 +
|
|
arch/mips/kernel/vmlinux.lds.S | 4 +--
|
|
include/asm-generic/vmlinux.lds.h | 63 ++++++++++++++++++++-------------------
|
|
7 files changed, 55 insertions(+), 51 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -294,6 +294,11 @@ else
|
|
scripts/Kbuild.include: ;
|
|
include scripts/Kbuild.include
|
|
|
|
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
|
|
+KBUILD_CFLAGS_KERNEL += -ffunction-sections -fdata-sections
|
|
+LDFLAGS_vmlinux += --gc-sections
|
|
+endif
|
|
+
|
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
|
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
|
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
|
@@ -785,11 +790,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
|
|
KBUILD_CFLAGS += $(call cc-option, -fno-inline-functions-called-once)
|
|
endif
|
|
|
|
-ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
|
|
-KBUILD_CFLAGS_KERNEL += -ffunction-sections -fdata-sections
|
|
-LDFLAGS_vmlinux += --gc-sections
|
|
-endif
|
|
-
|
|
# arch Makefile may override CC so keep this after arch Makefile is included
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
|
|
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -98,6 +98,7 @@ config ARM
|
|
select HAVE_UID16
|
|
select HAVE_VIRT_CPU_ACCOUNTING_GEN
|
|
select IRQ_FORCED_THREADING
|
|
+ select HAVE_LD_DEAD_CODE_DATA_ELIMINATION
|
|
select MODULES_USE_ELF_REL
|
|
select NEED_DMA_MAP_STATE
|
|
select NO_BOOTMEM
|
|
--- a/arch/arm/boot/compressed/Makefile
|
|
+++ b/arch/arm/boot/compressed/Makefile
|
|
@@ -106,6 +106,7 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
|
ORIG_CFLAGS := $(KBUILD_CFLAGS)
|
|
KBUILD_CFLAGS = $(subst -pg, , $(ORIG_CFLAGS))
|
|
endif
|
|
+KBUILD_CFLAGS_KERNEL := $(patsubst -f%-sections,,$(KBUILD_CFLAGS_KERNEL))
|
|
|
|
# -fstack-protector-strong triggers protection checks in this code,
|
|
# but it is being used too early to link to meaningful stack_chk logic.
|
|
--- a/arch/arm/kernel/vmlinux.lds.S
|
|
+++ b/arch/arm/kernel/vmlinux.lds.S
|
|
@@ -100,24 +100,24 @@ SECTIONS
|
|
}
|
|
.init.arch.info : {
|
|
__arch_info_begin = .;
|
|
- *(.arch.info.init)
|
|
+ KEEP(*(.arch.info.init))
|
|
__arch_info_end = .;
|
|
}
|
|
.init.tagtable : {
|
|
__tagtable_begin = .;
|
|
- *(.taglist.init)
|
|
+ KEEP(*(.taglist.init))
|
|
__tagtable_end = .;
|
|
}
|
|
#ifdef CONFIG_SMP_ON_UP
|
|
.init.smpalt : {
|
|
__smpalt_begin = .;
|
|
- *(.alt.smp.init)
|
|
+ KEEP(*(.alt.smp.init))
|
|
__smpalt_end = .;
|
|
}
|
|
#endif
|
|
.init.pv_table : {
|
|
__pv_table_begin = .;
|
|
- *(.pv_table)
|
|
+ KEEP(*(.pv_table))
|
|
__pv_table_end = .;
|
|
}
|
|
|
|
--- a/arch/arm/kernel/vmlinux.lds.h
|
|
+++ b/arch/arm/kernel/vmlinux.lds.h
|
|
@@ -22,13 +22,13 @@
|
|
#define ARM_MMU_DISCARD(x)
|
|
#else
|
|
#define ARM_MMU_KEEP(x)
|
|
-#define ARM_MMU_DISCARD(x) x
|
|
+#define ARM_MMU_DISCARD(x) KEEP(x)
|
|
#endif
|
|
|
|
#define PROC_INFO \
|
|
. = ALIGN(4); \
|
|
__proc_info_begin = .; \
|
|
- *(.proc.info.init) \
|
|
+ KEEP(*(.proc.info.init)) \
|
|
__proc_info_end = .;
|
|
|
|
#define HYPERVISOR_TEXT \
|
|
@@ -39,11 +39,11 @@
|
|
#define IDMAP_TEXT \
|
|
ALIGN_FUNCTION(); \
|
|
__idmap_text_start = .; \
|
|
- *(.idmap.text) \
|
|
+ KEEP(*(.idmap.text)) \
|
|
__idmap_text_end = .; \
|
|
. = ALIGN(PAGE_SIZE); \
|
|
__hyp_idmap_text_start = .; \
|
|
- *(.hyp.idmap.text) \
|
|
+ KEEP(*(.hyp.idmap.text)) \
|
|
__hyp_idmap_text_end = .;
|
|
|
|
#define ARM_DISCARD \
|
|
@@ -86,12 +86,12 @@
|
|
. = ALIGN(8); \
|
|
.ARM.unwind_idx : { \
|
|
__start_unwind_idx = .; \
|
|
- *(.ARM.exidx*) \
|
|
+ KEEP(*(.ARM.exidx*)) \
|
|
__stop_unwind_idx = .; \
|
|
} \
|
|
.ARM.unwind_tab : { \
|
|
__start_unwind_tab = .; \
|
|
- *(.ARM.extab*) \
|
|
+ KEEP(*(.ARM.extab*)) \
|
|
__stop_unwind_tab = .; \
|
|
}
|
|
|
|
@@ -102,14 +102,14 @@
|
|
#define ARM_VECTORS \
|
|
__vectors_start = .; \
|
|
.vectors 0xffff0000 : AT(__vectors_start) { \
|
|
- *(.vectors) \
|
|
+ KEEP(*(.vectors)) \
|
|
} \
|
|
. = __vectors_start + SIZEOF(.vectors); \
|
|
__vectors_end = .; \
|
|
\
|
|
__stubs_start = .; \
|
|
.stubs ADDR(.vectors) + 0x1000 : AT(__stubs_start) { \
|
|
- *(.stubs) \
|
|
+ KEEP(*(.stubs)) \
|
|
} \
|
|
. = __stubs_start + SIZEOF(.stubs); \
|
|
__stubs_end = .; \
|
|
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -43,6 +43,7 @@ config MIPS
|
|
select HAVE_ARCH_TRANSPARENT_HUGEPAGE if CPU_SUPPORTS_HUGEPAGES && 64BIT
|
|
select HAVE_CBPF_JIT if (!64BIT && !CPU_MICROMIPS)
|
|
select HAVE_EBPF_JIT if (64BIT && !CPU_MICROMIPS)
|
|
+ select HAVE_LD_DEAD_CODE_DATA_ELIMINATION
|
|
select HAVE_CONTEXT_TRACKING
|
|
select HAVE_COPY_THREAD_TLS
|
|
select HAVE_C_RECORDMCOUNT
|
|
--- a/arch/mips/kernel/vmlinux.lds.S
|
|
+++ b/arch/mips/kernel/vmlinux.lds.S
|
|
@@ -72,7 +72,7 @@ SECTIONS
|
|
/* Exception table for data bus errors */
|
|
__dbe_table : {
|
|
__start___dbe_table = .;
|
|
- *(__dbe_table)
|
|
+ KEEP(*(__dbe_table))
|
|
__stop___dbe_table = .;
|
|
}
|
|
|
|
@@ -123,7 +123,7 @@ SECTIONS
|
|
. = ALIGN(4);
|
|
.mips.machines.init : AT(ADDR(.mips.machines.init) - LOAD_OFFSET) {
|
|
__mips_machines_start = .;
|
|
- *(.mips.machines.init)
|
|
+ KEEP(*(.mips.machines.init))
|
|
__mips_machines_end = .;
|
|
}
|
|
|