mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-29 10:08:59 +00:00
e1d6013935
Source archive format changed to tar.xz Removed upstreamed 020-treewide-use-uint-instead-of-u_int.patch 030-revert-fix-build-for-missing-ETH_ALEN-definition.patch 040-xshared-Fix-build-for-Werror-format-security.patch 050-build-fix-error-during-out-of-tree-build.patch 060-libxtables-unexport-init_extensions-declarations.patch 070-extensions-string-Review-parse_string-function.patch 104-nft-track-each-register-individually.patch Manually rebased 600-shared-libext.patch Change netfiletr.mk due to module name change https://git.netfilter.org/iptables/commit/?id=f30c5edce0413b2b2346c7f58e801f10f6e9bc5a Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16641 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
28 lines
606 B
Diff
28 lines
606 B
Diff
--- a/libxtables/xtables.c
|
|
+++ b/libxtables/xtables.c
|
|
@@ -475,7 +475,7 @@ char *xtables_strdup(const char *s)
|
|
return dup;
|
|
}
|
|
|
|
-static char *get_modprobe(void)
|
|
+__attribute__((unused)) static char *get_modprobe(void)
|
|
{
|
|
int procfile;
|
|
char *ret;
|
|
@@ -505,6 +505,7 @@ static char *get_modprobe(void)
|
|
|
|
int xtables_insmod(const char *modname, const char *modprobe, bool quiet)
|
|
{
|
|
+#if 0
|
|
char *buf = NULL;
|
|
char *argv[4];
|
|
int status;
|
|
@@ -539,6 +540,7 @@ int xtables_insmod(const char *modname,
|
|
free(buf);
|
|
if (WIFEXITED(status) && WEXITSTATUS(status) == 0)
|
|
return 0;
|
|
+#endif
|
|
return -1;
|
|
}
|
|
|